# CVE-2021-23443: Cross-site Scripting (XSS)

> Attackers can execute arbitrary scripts by exploiting type confusion in edge.js to bypass input sanitization when rendering arrays.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Sep 2021
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-55r9-7mf8-m382, SNYK-JS-EDGEJS-1579556

## What is CVE-2021-23443?

CVE-2021-23443 is a medium-severity cross-site scripting vulnerability in edge.js, published on 21 Sep 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

This affects the package edge.js before 5.3.2. A type confusion vulnerability can be used to bypass input sanitization when the input to be rendered is an array (instead of a string or a SafeValue), even if {{ }} are used.

Weakness: CWE-843 (Access of Resource Using Incompatible Type)

## Which versions are affected by CVE-2021-23443?

2 open source packages ship an affected version, including edge.js. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `edge.js` | npm | All versions | 5.3.2 |
| `edge.js` | npm | All versions | 5.3.2 |

Products: Adonisjs Edge.

## How do I fix CVE-2021-23443?

Upgrade edge.js to 5.3.2 or later.

## Is CVE-2021-23443 being exploited?

There is no known exploitation of CVE-2021-23443 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-23443 and fix it if it is affected.

What it is: CVE-2021-23443 is a medium-severity cross-site scripting vulnerability in edge.js, published on 21 Sep 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-23443 in the wild and no public exploit code.

Affected packages and fixed versions:
- edge.js (npm): affected all versions; fixed in 5.3.2
- edge.js (npm): affected all versions; fixed in 5.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-23443/ (Markdown: https://insights.sbomify.com/CVE-2021-23443/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-23443
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-23443
- OSV: https://osv.dev/vulnerability/CVE-2021-23443

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-23443/
Summaries are generated and may contain mistakes; the official description above is the record.
