# CVE-2021-23445: Cross-site Scripting (XSS)

> An attacker can execute arbitrary scripts via unescaped array inputs in the HTML escape function of the datatables.net library.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Sep 2021
- **Updated:** 16 Sep 2024
- **Also known as:** AZL-66567, DEBIAN-CVE-2021-23445, DLA-3529-1, GHSA-h73q-5wmj-q8pj, UBUNTU-CVE-2021-23445

## What is CVE-2021-23445?

CVE-2021-23445 is a low-severity cross-site scripting vulnerability in datatables.net, published on 27 Sep 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

This affects the package datatables.net before 1.11.3. If an array is passed to the HTML escape entities function it would not have its contents escaped.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-23445?

2 open source packages ship an affected version, including datatables.net. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `datatables.net` | npm | All versions | 1.11.3 |
| `datatables.net` | npm | All versions | 1.11.3 |

Products: Datatables Datatables.net.

## How do I fix CVE-2021-23445?

Upgrade datatables.net to 1.11.3 or later.

## Is CVE-2021-23445 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-23445 exists.

## Other vulnerabilities in datatables.net

- [CVE-2020-28458](https://insights.sbomify.com/CVE-2020-28458/): Prototype Pollution (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-23445 and fix it if it is affected.

What it is: CVE-2021-23445 is a low-severity cross-site scripting vulnerability in datatables.net, published on 27 Sep 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-23445 exists.

Affected packages and fixed versions:
- datatables.net (npm): affected all versions; fixed in 1.11.3
- datatables.net (npm): affected all versions; fixed in 1.11.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-23445/ (Markdown: https://insights.sbomify.com/CVE-2021-23445/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-23445
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-23445
- OSV: https://osv.dev/vulnerability/CVE-2021-23445

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-23445/
Summaries are generated and may contain mistakes; the official description above is the record.
