# CVE-2021-23446: Regular Expression Denial of Service (ReDoS)

> Attackers can cause a denial of service in Handsontable via a Regular Expression Denial of Service vulnerability in the isNumeric helper function.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Sep 2021
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-hf66-r44g-p7j9

## What is CVE-2021-23446?

CVE-2021-23446 is a high-severity denial of service vulnerability in Handsontable, published on 29 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The package handsontable before 10.0.0; the package handsontable from 0 and before 10.0.0 are vulnerable to Regular Expression Denial of Service (ReDoS) in Handsontable.helper.isNumeric function.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2021-23446?

2 open source packages ship an affected version, including handsontable. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `handsontable` | npm | All versions | 10.0.0 |
| `handsontable` | npm | All versions | 10.0.0 |

Products: Handsontable Handsontable.

## How do I fix CVE-2021-23446?

Upgrade handsontable to 10.0.0 or later.

## Is CVE-2021-23446 being exploited?

There is no known exploitation of CVE-2021-23446 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-23446 and fix it if it is affected.

What it is: CVE-2021-23446 is a high-severity denial of service vulnerability in Handsontable, published on 29 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-23446 in the wild and no public exploit code.

Affected packages and fixed versions:
- handsontable (npm): affected all versions; fixed in 10.0.0
- handsontable (npm): affected all versions; fixed in 10.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-23446/ (Markdown: https://insights.sbomify.com/CVE-2021-23446/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-23446
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-23446
- OSV: https://osv.dev/vulnerability/CVE-2021-23446

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-23446/
Summaries are generated and may contain mistakes; the official description above is the record.
