{"answers":{"affected":"2 open source packages ship an affected version, including otp-generator. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-23451 in the wild and no public exploit code.","fix":"Upgrade otp-generator to 3.0.0 or later.","what":"CVE-2021-23451 is a medium-severity vulnerability in otp-generator, published on 25 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-23451 and fix it if it is affected.\n\nWhat it is: CVE-2021-23451 is a medium-severity vulnerability in otp-generator, published on 25 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-23451 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- otp-generator (npm): affected all versions; fixed in 3.0.0\n- otp-generator (npm): affected all versions; fixed in 3.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-23451/ (Markdown: https://insights.sbomify.com/CVE-2021-23451/index.md)","id":"CVE-2021-23451","markdown":"https://insights.sbomify.com/CVE-2021-23451/index.md","name":"CVE-2021-23451","record":{"aliases":["GHSA-6x93-h9g3-9phr"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"npm OTP library","requires_auth":"none","summary":"Insecure random number generation in the otp-generator library allows attackers to brute-force one-time passwords and potentially take over accounts.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"otp-generator","vendor":"otp-generator_project"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-330","name":"Use of Insufficiently Random Values"}],"description":"The package otp-generator before 3.0.0 are vulnerable to Insecure Randomness due to insecure generation of random one-time passwords, which may allow a brute-force attack.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Insecure Randomness","id":"CVE-2021-23451","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"weak_cryptography","year":"2021"},"n_packages":2,"n_references":3,"next":{"headline":"Prototype Pollution","id":"CVE-2021-23452"},"packages":[{"ecosystem":"npm","fixed":["3.0.0"],"introduced":["0"],"last_affected":[],"package":"otp-generator","purl":null,"source":"GHSA-6x93-h9g3-9phr"},{"ecosystem":"npm","fixed":["3.0.0"],"introduced":["0"],"last_affected":[],"package":"otp-generator","purl":"pkg:npm/otp-generator","source":"GHSA-6x93-h9g3-9phr"}],"prev":{"headline":"Prototype Pollution","id":"CVE-2021-23450"},"products":["otp-generator"],"published":"2022-07-25","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"Insecure random number generation in the otp-generator library allows attackers to brute-force one-time passwords and potentially take over accounts.","url":"https://insights.sbomify.com/CVE-2021-23451/"}