# CVE-2021-23484: Arbitrary File Write via Archive Extraction (Zip Slip)

> Attackers can write arbitrary files outside the intended directory via crafted zip archives in the zip-local library.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jan 2022
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-wxj7-97fp-j53j, SNYK-JS-ZIPLOCAL-2327477

## What is CVE-2021-23484?

CVE-2021-23484 is a critical path traversal vulnerability in n/a, published on 28 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The package zip-local before 0.3.5 are vulnerable to Arbitrary File Write via Archive Extraction (Zip Slip) which can lead to an extraction of a crafted file outside the intended extraction directory.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2021-23484?

2 open source packages ship an affected version, including zip-local. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `zip-local` | npm | All versions | 0.3.5 |
| `zip-local` | npm | All versions | 0.3.5 |

Products: Zip-Local Project Zip-Local.

## How do I fix CVE-2021-23484?

Upgrade zip-local to 0.3.5 or later.

## Is CVE-2021-23484 being exploited?

There is no known exploitation of CVE-2021-23484 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-23484 and fix it if it is affected.

What it is: CVE-2021-23484 is a critical path traversal vulnerability in n/a, published on 28 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-23484 in the wild and no public exploit code.

Affected packages and fixed versions:
- zip-local (npm): affected all versions; fixed in 0.3.5
- zip-local (npm): affected all versions; fixed in 0.3.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-23484/ (Markdown: https://insights.sbomify.com/CVE-2021-23484/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-23484
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-23484
- OSV: https://osv.dev/vulnerability/CVE-2021-23484

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-23484/
Summaries are generated and may contain mistakes; the official description above is the record.
