# CVE-2021-23555: Sandbox Bypass

> Attackers can bypass the vm2 sandbox to execute arbitrary code on the host machine by accessing internal error objects during stack trace generation.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Feb 2022
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-6pw2-5hjv-9pf7, SNYK-JS-VM2-2309905

## What is CVE-2021-23555?

CVE-2021-23555 is a critical code injection vulnerability in vm2, published on 11 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The package vm2 before 3.9.6 are vulnerable to Sandbox Bypass via direct access to host error objects generated by node internals during generation of a stacktraces, which can lead to execution of arbitrary code on the host machine.

## Which versions are affected by CVE-2021-23555?

2 open source packages ship an affected version, including vm2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vm2` | npm | All versions | 3.9.6 |
| `vm2` | npm | All versions | 3.9.6 |

Products: Vm2 Project Vm2.

## How do I fix CVE-2021-23555?

Upgrade vm2 to 3.9.6 or later.

## Is CVE-2021-23555 being exploited?

There is no known exploitation of CVE-2021-23555 in the wild and no public exploit code.

## Other vulnerabilities in vm2

- [CVE-2026-43997](https://insights.sbomify.com/CVE-2026-43997/): vm2: Sandbox Escape (critical 10.0)
- [CVE-2026-44005](https://insights.sbomify.com/CVE-2026-44005/): vm2: Sandbox escape (critical 10.0)
- [CVE-2026-44006](https://insights.sbomify.com/CVE-2026-44006/): vm2: Sandbox Escape (critical 10.0)
- [CVE-2023-29017](https://insights.sbomify.com/CVE-2023-29017/): vm2 Sandbox Escape vulnerability (critical 10.0)
- [CVE-2022-36067](https://insights.sbomify.com/CVE-2022-36067/): vm2 vulnerable to Sandbox Escape before v3.9.11 (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-23555 and fix it if it is affected.

What it is: CVE-2021-23555 is a critical code injection vulnerability in vm2, published on 11 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-23555 in the wild and no public exploit code.

Affected packages and fixed versions:
- vm2 (npm): affected all versions; fixed in 3.9.6
- vm2 (npm): affected all versions; fixed in 3.9.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-23555/ (Markdown: https://insights.sbomify.com/CVE-2021-23555/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-23555
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-23555
- OSV: https://osv.dev/vulnerability/CVE-2021-23555

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-23555/
Summaries are generated and may contain mistakes; the official description above is the record.
