{"answers":{"affected":"3 open source packages ship an affected version, including guake. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-23556 in the wild and no public exploit code.","fix":"Upgrade guake to 3.8.5 or later.","what":"CVE-2021-23556 is a medium-severity command injection vulnerability in guake, published on 17 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-23556 and fix it if it is affected.\n\nWhat it is: CVE-2021-23556 is a medium-severity command injection vulnerability in guake, published on 17 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-23556 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- guake (PyPI): affected all versions; fixed in 3.8.5\n- guake (PyPI): affected all versions; fixed in 3.8.5\n- guake (PyPI): affected all versions; fixed in 3.8.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-23556/ (Markdown: https://insights.sbomify.com/CVE-2021-23556/index.md)","id":"CVE-2021-23556","markdown":"https://insights.sbomify.com/CVE-2021-23556/index.md","name":"CVE-2021-23556","record":{"aliases":["DEBIAN-CVE-2021-23556","GHSA-7x48-7466-3g33","PYSEC-2022-165","SNYK-PYTHON-GUAKE-2386334","UBUNTU-CVE-2021-23556"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Guake terminal emulator","requires_auth":"low_privilege","summary":"A malicious user can execute arbitrary commands via the D-Bus interface if another malicious program is installed to send signals.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"guake","vendor":"guake-project"}],"cvss":{"score":6.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:L/A:L/E:P","version":"3.1"},"cwes":[],"description":"The package guake before 3.8.5 are vulnerable to Exposed Dangerous Method or Function due to the exposure of execute_command and execute_command_by_uuid methods via the d-bus interface, which makes it possible for a malicious user to run an arbitrary command via the d-bus method. **Note:** Exploitation requires the user to have installed another malicious program that will be able to send dbus signals or run terminal commands.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Exposed Dangerous Method or Function","id":"CVE-2021-23556","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"command_injection","year":"2021"},"n_packages":3,"n_references":5,"next":{"headline":"Prototype Pollution","id":"CVE-2021-23558"},"packages":[{"ecosystem":"PyPI","fixed":["3.8.5"],"introduced":["0"],"last_affected":[],"package":"guake","purl":null,"source":"GHSA-7x48-7466-3g33"},{"ecosystem":"PyPI","fixed":["3.8.5"],"introduced":["0"],"last_affected":[],"package":"guake","purl":"pkg:pypi/guake","source":"GHSA-7x48-7466-3g33"},{"ecosystem":"PyPI","fixed":["3.8.5"],"introduced":["0"],"last_affected":[],"package":"guake","purl":"pkg:pypi/guake","source":"PYSEC-2022-165"}],"prev":{"headline":"Sandbox Bypass","id":"CVE-2021-23555"},"products":["guake"],"published":"2022-03-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"A malicious user can execute arbitrary commands via the D-Bus interface if another malicious program is installed to send signals.","url":"https://insights.sbomify.com/CVE-2021-23556/"}