# CVE-2021-23556: Exposed Dangerous Method or Function

> A malicious user can execute arbitrary commands via the D-Bus interface if another malicious program is installed to send signals.

- **Severity:** Medium 6.4 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:L/A:L/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Mar 2022
- **Updated:** 17 Sep 2024
- **Also known as:** DEBIAN-CVE-2021-23556, GHSA-7x48-7466-3g33, PYSEC-2022-165, SNYK-PYTHON-GUAKE-2386334, UBUNTU-CVE-2021-23556

## What is CVE-2021-23556?

CVE-2021-23556 is a medium-severity command injection vulnerability in guake, published on 17 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The package guake before 3.8.5 are vulnerable to Exposed Dangerous Method or Function due to the exposure of execute_command and execute_command_by_uuid methods via the d-bus interface, which makes it possible for a malicious user to run an arbitrary command via the d-bus method. **Note:** Exploitation requires the user to have installed another malicious program that will be able to send dbus signals or run terminal commands.

## Which versions are affected by CVE-2021-23556?

3 open source packages ship an affected version, including guake. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `guake` | PyPI | All versions | 3.8.5 |
| `guake` | PyPI | All versions | 3.8.5 |
| `guake` | PyPI | All versions | 3.8.5 |

Products: Guake-Project Guake.

## How do I fix CVE-2021-23556?

Upgrade guake to 3.8.5 or later.

## Is CVE-2021-23556 being exploited?

There is no known exploitation of CVE-2021-23556 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-23556 and fix it if it is affected.

What it is: CVE-2021-23556 is a medium-severity command injection vulnerability in guake, published on 17 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-23556 in the wild and no public exploit code.

Affected packages and fixed versions:
- guake (PyPI): affected all versions; fixed in 3.8.5
- guake (PyPI): affected all versions; fixed in 3.8.5
- guake (PyPI): affected all versions; fixed in 3.8.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-23556/ (Markdown: https://insights.sbomify.com/CVE-2021-23556/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-23556
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-23556
- OSV: https://osv.dev/vulnerability/CVE-2021-23556

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-23556/
Summaries are generated and may contain mistakes; the official description above is the record.
