# CVE-2021-23566: Information Exposure

> Attackers can reproduce the last generated ID via the valueOf function, leading to information exposure in applications using the nanoid library.

- **Severity:** Medium 4.0 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jan 2022
- **Updated:** 3 Nov 2025
- **Also known as:** DEBIAN-CVE-2021-23566, GHSA-qrpm-p2h7-hrv2, UBUNTU-CVE-2021-23566

## What is CVE-2021-23566?

CVE-2021-23566 is a medium-severity vulnerability in nanoid, published on 14 Jan 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

The package nanoid from 3.0.0 and before 3.1.31 are vulnerable to Information Exposure via the valueOf() function which allows to reproduce the last id generated.

Weakness: CWE-704 (Incorrect Type Conversion or Cast)

## Which versions are affected by CVE-2021-23566?

2 open source packages ship an affected version, including nanoid. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nanoid` | npm | From 3.0.0 | 3.1.31 |
| `nanoid` | npm | From 3.0.0 | 3.1.31 |

Products: Nanoid Project Nanoid.

## How do I fix CVE-2021-23566?

Upgrade nanoid to 3.1.31 or later.

## Is CVE-2021-23566 being exploited?

There is no known exploitation of CVE-2021-23566 in the wild and no public exploit code.

## Other vulnerabilities in nanoid

- [CVE-2026-67213](https://insights.sbomify.com/CVE-2026-67213/): nanoid before 5.1.6 Infinite Loop via Zero Size in customAlphabet and customRandom (high 8.2)
- [CVE-2026-67214](https://insights.sbomify.com/CVE-2026-67214/): nanoid Infinite Loop via Negative Size in non-secure module (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-23566 and fix it if it is affected.

What it is: CVE-2021-23566 is a medium-severity vulnerability in nanoid, published on 14 Jan 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-23566 in the wild and no public exploit code.

Affected packages and fixed versions:
- nanoid (npm): affected from 3.0.0; fixed in 3.1.31
- nanoid (npm): affected from 3.0.0; fixed in 3.1.31

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-23566/ (Markdown: https://insights.sbomify.com/CVE-2021-23566/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-23566
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-23566
- OSV: https://osv.dev/vulnerability/CVE-2021-23566

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-23566/
Summaries are generated and may contain mistakes; the official description above is the record.
