# CVE-2021-23568: Prototype Pollution

> Attackers can pollute JavaScript object prototypes via unsafe recursive merge, potentially leading to code execution or privilege escalation.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jan 2022
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-gjm5-83cw-p3p2, SNYK-JS-EXTEND2-2320315

## What is CVE-2021-23568?

CVE-2021-23568 is a high-severity vulnerability in extend2, published on 7 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The package extend2 before 1.0.1 are vulnerable to Prototype Pollution via the extend function due to unsafe recursive merge.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2021-23568?

2 open source packages ship an affected version, including extend2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `extend2` | npm | All versions | 1.0.1 |
| `extend2` | npm | All versions | 1.0.1 |

Products: Eggjs Extend2.

## How do I fix CVE-2021-23568?

Upgrade extend2 to 1.0.1 or later.

## Is CVE-2021-23568 being exploited?

There is no known exploitation of CVE-2021-23568 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-23568 and fix it if it is affected.

What it is: CVE-2021-23568 is a high-severity vulnerability in extend2, published on 7 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-23568 in the wild and no public exploit code.

Affected packages and fixed versions:
- extend2 (npm): affected all versions; fixed in 1.0.1
- extend2 (npm): affected all versions; fixed in 1.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-23568/ (Markdown: https://insights.sbomify.com/CVE-2021-23568/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-23568
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-23568
- OSV: https://osv.dev/vulnerability/CVE-2021-23568

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-23568/
Summaries are generated and may contain mistakes; the official description above is the record.
