# CVE-2021-23664: Server-side Request Forgery (SSRF)

> An attacker can exploit missing validation in the isomorphic-git CORS proxy to perform Server-side Request Forgery attacks.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Jan 2022
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-v82v-rq72-phq9, SNYK-JS-ISOMORPHICGITCORSPROXY-1734788

## What is CVE-2021-23664?

CVE-2021-23664 is a high-severity server-side request forgery vulnerability in @isomorphic-git/cors-proxy, published on 21 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The package @isomorphic-git/cors-proxy before 2.7.1 are vulnerable to Server-side Request Forgery (SSRF) due to missing sanitization and validation of the redirection action in middleware.js.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2021-23664?

2 open source packages ship an affected version, including @isomorphic-git/cors-proxy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@isomorphic-git/cors-proxy` | npm | All versions | 2.7.1 |
| `@isomorphic-git/cors-proxy` | npm | All versions | 2.7.1 |

Products: Isomorphic-Git Cors-Proxy.

## How do I fix CVE-2021-23664?

Upgrade @isomorphic-git/cors-proxy to 2.7.1 or later.

## Is CVE-2021-23664 being exploited?

There is no known exploitation of CVE-2021-23664 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-23664 and fix it if it is affected.

What it is: CVE-2021-23664 is a high-severity server-side request forgery vulnerability in @isomorphic-git/cors-proxy, published on 21 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-23664 in the wild and no public exploit code.

Affected packages and fixed versions:
- @isomorphic-git/cors-proxy (npm): affected all versions; fixed in 2.7.1
- @isomorphic-git/cors-proxy (npm): affected all versions; fixed in 2.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-23664/ (Markdown: https://insights.sbomify.com/CVE-2021-23664/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-23664
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-23664
- OSV: https://osv.dev/vulnerability/CVE-2021-23664

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-23664/
Summaries are generated and may contain mistakes; the official description above is the record.
