{"answers":{"affected":"2 open source packages ship an affected version, including ssrf-agent. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-23718 in the wild and no public exploit code.","fix":"Upgrade ssrf-agent to 1.0.5 or later.","what":"CVE-2021-23718 is a medium-severity server-side request forgery vulnerability in ssrf-agent, published on 22 Nov 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-23718 and fix it if it is affected.\n\nWhat it is: CVE-2021-23718 is a medium-severity server-side request forgery vulnerability in ssrf-agent, published on 22 Nov 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-23718 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ssrf-agent (npm): affected all versions; fixed in 1.0.5\n- ssrf-agent (npm): affected all versions; fixed in 1.0.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-23718/ (Markdown: https://insights.sbomify.com/CVE-2021-23718/index.md)","id":"CVE-2021-23718","markdown":"https://insights.sbomify.com/CVE-2021-23718/index.md","name":"CVE-2021-23718","record":{"aliases":["GHSA-6gww-qpm6-mc2g"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js SSRF library","requires_auth":"none","summary":"Attackers can bypass IP validation to access internal resources via the defaultIpChecker function in the ssrf-agent library.","user_interaction":"required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"ssrf-agent","vendor":"ssrf-agent_project"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N/E:P","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"The package ssrf-agent before 1.0.5 are vulnerable to Server-side Request Forgery (SSRF) via the defaultIpChecker function. It fails to properly validate if the IP requested is private.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Server-side Request Forgery (SSRF)","id":"CVE-2021-23718","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"ssrf","year":"2021"},"n_packages":2,"n_references":3,"next":{"headline":"Stored Command Injection","id":"CVE-2021-23727"},"packages":[{"ecosystem":"npm","fixed":["1.0.5"],"introduced":["0"],"last_affected":[],"package":"ssrf-agent","purl":null,"source":"GHSA-6gww-qpm6-mc2g"},{"ecosystem":"npm","fixed":["1.0.5"],"introduced":["0"],"last_affected":[],"package":"ssrf-agent","purl":"pkg:npm/ssrf-agent","source":"GHSA-6gww-qpm6-mc2g"}],"prev":{"headline":"Prototype Pollution","id":"CVE-2021-23702"},"products":["ssrf-agent"],"published":"2021-11-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Attackers can bypass IP validation to access internal resources via the defaultIpChecker function in the ssrf-agent library.","url":"https://insights.sbomify.com/CVE-2021-23718/"}