{"answers":{"affected":"3 open source packages ship an affected version, including celery. It affects 3 products.","exploited":"There is no known exploitation of CVE-2021-23727 in the wild and no public exploit code.","fix":"Upgrade celery to 5.2.2 or later.","what":"CVE-2021-23727 is a high-severity command injection vulnerability in Fedoraproject Extra Packages for Enterprise Linux, published on 29 Dec 2021. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-23727 and fix it if it is affected.\n\nWhat it is: CVE-2021-23727 is a high-severity command injection vulnerability in Fedoraproject Extra Packages for Enterprise Linux, published on 29 Dec 2021. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-23727 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- celery (PyPI): affected all versions; fixed in 5.2.2\n- celery (PyPI): affected all versions; fixed in 5.2.2\n- celery (PyPI): affected all versions; fixed in 5.2.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-23727/ (Markdown: https://insights.sbomify.com/CVE-2021-23727/index.md)","id":"CVE-2021-23727","markdown":"https://insights.sbomify.com/CVE-2021-23727/index.md","name":"CVE-2021-23727","record":{"aliases":["CLSA-2025-1756771909","CLSA-2026-1770250308","DEBIAN-CVE-2021-23727","GHSA-q4xr-rc97-m4xx","MGASA-2022-0029","PYSEC-2021-858","SNYK-PYTHON-CELERY-2314953","UBUNTU-CVE-2021-23727"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Celery task queue library","requires_auth":"low_privilege","summary":"An attacker with backend access can inject commands via task metadata, leading to remote code execution in applications using Celery.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"celery","vendor":"celeryproject"},{"product":"extra_packages_for_enterprise_linux","vendor":"fedoraproject"},{"product":"fedora","vendor":"fedoraproject"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H/E:P/RL:O/RC:C","version":"3.1"},"cwes":[{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"}],"description":"This affects the package celery before 5.2.2. It by default trusts the messages and metadata stored in backends (result stores). When reading task metadata from the backend, the data is deserialized. Given that an attacker can gain access to, or somehow manipulate the metadata within a celery backend, they could trigger a stored command injection vulnerability and potentially gain further access to the system.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Stored Command Injection","id":"CVE-2021-23727","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"fedoraproject:extra_packages_for_enterprise_linux","products":["fedoraproject:extra_packages_for_enterprise_linux","fedoraproject:fedora"],"type":"command_injection","year":"2021"},"n_packages":3,"n_references":3,"next":{"headline":"Arbitrary Code Execution","id":"CVE-2021-23732"},"packages":[{"ecosystem":"PyPI","fixed":["5.2.2"],"introduced":["0"],"last_affected":[],"package":"celery","purl":null,"source":"GHSA-q4xr-rc97-m4xx"},{"ecosystem":"PyPI","fixed":["5.2.2"],"introduced":["0"],"last_affected":[],"package":"celery","purl":"pkg:pypi/celery","source":"GHSA-q4xr-rc97-m4xx"},{"ecosystem":"PyPI","fixed":["5.2.2"],"introduced":["0"],"last_affected":[],"package":"celery","purl":"pkg:pypi/celery","source":"PYSEC-2021-858"}],"prev":{"headline":"Server-side Request Forgery (SSRF)","id":"CVE-2021-23718"},"products":["celery"],"published":"2021-12-29","related":[{"cvss_score":6.9,"headline":"Celery local privilege escalation vulnerability","id":"CVE-2011-4356","kev_date_added":null,"published":"2011-12-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"An attacker with backend access can inject commands via task metadata, leading to remote code execution in applications using Celery.","url":"https://insights.sbomify.com/CVE-2021-23727/"}