# CVE-2021-23727: Stored Command Injection

> An attacker with backend access can inject commands via task metadata, leading to remote code execution in applications using Celery.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H/E:P/RL:O/RC:C`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Dec 2021
- **Updated:** 16 Sep 2024
- **Also known as:** CLSA-2025-1756771909, CLSA-2026-1770250308, DEBIAN-CVE-2021-23727, GHSA-q4xr-rc97-m4xx, MGASA-2022-0029, PYSEC-2021-858, SNYK-PYTHON-CELERY-2314953, UBUNTU-CVE-2021-23727

## What is CVE-2021-23727?

CVE-2021-23727 is a high-severity command injection vulnerability in Fedoraproject Extra Packages for Enterprise Linux, published on 29 Dec 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

This affects the package celery before 5.2.2. It by default trusts the messages and metadata stored in backends (result stores). When reading task metadata from the backend, the data is deserialized. Given that an attacker can gain access to, or somehow manipulate the metadata within a celery backend, they could trigger a stored command injection vulnerability and potentially gain further access to the system.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2021-23727?

3 open source packages ship an affected version, including celery. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `celery` | PyPI | All versions | 5.2.2 |
| `celery` | PyPI | All versions | 5.2.2 |
| `celery` | PyPI | All versions | 5.2.2 |

Products: Celeryproject Celery, Fedoraproject Extra Packages for Enterprise Linux, Fedoraproject Fedora.

## How do I fix CVE-2021-23727?

Upgrade celery to 5.2.2 or later.

## Is CVE-2021-23727 being exploited?

There is no known exploitation of CVE-2021-23727 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Extra Packages for Enterprise Linux

- [CVE-2011-4356](https://insights.sbomify.com/CVE-2011-4356/): Celery local privilege escalation vulnerability (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-23727 and fix it if it is affected.

What it is: CVE-2021-23727 is a high-severity command injection vulnerability in Fedoraproject Extra Packages for Enterprise Linux, published on 29 Dec 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-23727 in the wild and no public exploit code.

Affected packages and fixed versions:
- celery (PyPI): affected all versions; fixed in 5.2.2
- celery (PyPI): affected all versions; fixed in 5.2.2
- celery (PyPI): affected all versions; fixed in 5.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-23727/ (Markdown: https://insights.sbomify.com/CVE-2021-23727/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-23727
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-23727
- OSV: https://osv.dev/vulnerability/CVE-2021-23727

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-23727/
Summaries are generated and may contain mistakes; the official description above is the record.
