# CVE-2021-23758: Ajax.NET Professional Deserialization of Untrusted Data

> Attackers can achieve remote code execution by exploiting unsafe deserialization of arbitrary .NET classes in the AjaxPro.2 library.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Yes, since 26 Aug 2026 (CISA KEV)
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Dec 2021
- **Updated:** 27 Aug 2026
- **Also known as:** GHSA-6r7c-6w96-8pvw, SNYK-DOTNET-AJAXPRO2-1925971

## What is CVE-2021-23758?

CVE-2021-23758 is a high-severity unsafe deserialization vulnerability in AjaxPro.2, published on 3 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

All versions of package ajaxpro.2 are vulnerable to Deserialization of Untrusted Data due to the possibility of deserialization of arbitrary .NET classes, which can be abused to gain remote code execution.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2021-23758?

2 open source packages ship an affected version, including AjaxNetProfessional. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `AjaxNetProfessional` | NuGet | All versions | 21.11.29.1 |
| `AjaxNetProfessional` | NuGet | All versions | 21.11.29.1 |

Products: Ajaxpro.2 Project Ajaxpro.2, Michaelschwarz Ajax.net Professional.

## How do I fix CVE-2021-23758?

Upgrade AjaxNetProfessional to 21.11.29.1 or later. US federal agencies must fix it by 9 Sep 2026.

## Is CVE-2021-23758 being exploited?

Yes. Attackers have exploited CVE-2021-23758 in the wild since at least 26 Aug 2026.

Public exploit code:

- https://github.com/numanturle/CVE-2021-23758-POC (github_poc): https://github.com/numanturle/CVE-2021-23758-POC
- AjaxPro Deserialization Remote Code Execution (metasploit)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-23758 and fix it if it is affected.

What it is: CVE-2021-23758 is a high-severity unsafe deserialization vulnerability in AjaxPro.2, published on 3 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2021-23758 in the wild since at least 26 Aug 2026.

Affected packages and fixed versions:
- AjaxNetProfessional (NuGet): affected all versions; fixed in 21.11.29.1
- AjaxNetProfessional (NuGet): affected all versions; fixed in 21.11.29.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-23758/ (Markdown: https://insights.sbomify.com/CVE-2021-23758/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-23758
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-23758
- OSV: https://osv.dev/vulnerability/CVE-2021-23758

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-23758/
Summaries are generated and may contain mistakes; the official description above is the record.
