# CVE-2021-23803: Access Control Bypass

> Attackers can bypass function restrictions in the Latte template engine by injecting control characters, potentially leading to unauthorized code execution.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Dec 2021
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-6pj2-5fqq-xvjc, SNYK-PHP-LATTELATTE-1932226, UBUNTU-CVE-2021-23803

## What is CVE-2021-23803?

CVE-2021-23803 is a critical vulnerability in latte/latte, published on 17 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

This affects the package latte/latte before 2.10.6. There is a way to bypass allowFunctions that will affect the security of the application. When the template is set to allow/disallow the use of certain functions, adding control characters (x00-x08) after the function will bypass these restrictions.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2021-23803?

2 open source packages ship an affected version, including latte/latte. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `latte/latte` | Packagist | All versions | 2.10.6 |
| `latte/latte` | Packagist | All versions | 2.10.6 |

Products: Nette Latte.

## How do I fix CVE-2021-23803?

Upgrade latte/latte to 2.10.6 or later.

## Is CVE-2021-23803 being exploited?

There is no known exploitation of CVE-2021-23803 in the wild and no public exploit code.

## Other vulnerabilities in latte/latte

- [CVE-2022-21648](https://insights.sbomify.com/CVE-2022-21648/): Sandbox bypass in Latte templates (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-23803 and fix it if it is affected.

What it is: CVE-2021-23803 is a critical vulnerability in latte/latte, published on 17 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-23803 in the wild and no public exploit code.

Affected packages and fixed versions:
- latte/latte (Packagist): affected all versions; fixed in 2.10.6
- latte/latte (Packagist): affected all versions; fixed in 2.10.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-23803/ (Markdown: https://insights.sbomify.com/CVE-2021-23803/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-23803
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-23803
- OSV: https://osv.dev/vulnerability/CVE-2021-23803

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-23803/
Summaries are generated and may contain mistakes; the official description above is the record.
