# CVE-2021-23807: Prototype Pollution

> A type confusion vulnerability in the jsonpointer library allows bypassing previous prototype pollution fixes when array components are used.

- **Severity:** Medium 5.6 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L/E:P/RL:O/RC:C`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Nov 2021
- **Updated:** 16 Sep 2024
- **Also known as:** CLSA-2026-1772756022, CLSA-2026-1773706629, CLSA-2026-1773965925, GHSA-282f-qqgm-c34q, OESA-2022-1755

## What is CVE-2021-23807?

CVE-2021-23807 is a medium-severity vulnerability in jsonpointer, published on 3 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

This affects the package jsonpointer before 5.0.0. A type confusion vulnerability can lead to a bypass of a previous Prototype Pollution fix when the pointer components are arrays.

Weakness: CWE-843 (Access of Resource Using Incompatible Type)

## Which versions are affected by CVE-2021-23807?

4 open source packages ship an affected version, including jsonpointer and org.webjars.npm:json-pointer. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jsonpointer` | npm | All versions | 5.0.0 |
| `jsonpointer` | npm | All versions | 5.0.0 |
| `org.webjars.npm:json-pointer` | npm | All versions | 5.0.0 |
| `org.webjars.npm:json-pointer` | npm | All versions | 5.0.0 |

Products: Janl Jsonpointer.

## How do I fix CVE-2021-23807?

Upgrade jsonpointer to 5.0.0 or later.

## Is CVE-2021-23807 being exploited?

There is no known exploitation of CVE-2021-23807 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-23807 and fix it if it is affected.

What it is: CVE-2021-23807 is a medium-severity vulnerability in jsonpointer, published on 3 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-23807 in the wild and no public exploit code.

Affected packages and fixed versions:
- jsonpointer (npm): affected all versions; fixed in 5.0.0
- jsonpointer (npm): affected all versions; fixed in 5.0.0
- org.webjars.npm:json-pointer (npm): affected all versions; fixed in 5.0.0
- org.webjars.npm:json-pointer (npm): affected all versions; fixed in 5.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-23807/ (Markdown: https://insights.sbomify.com/CVE-2021-23807/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-23807
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-23807
- OSV: https://osv.dev/vulnerability/CVE-2021-23807

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-23807/
Summaries are generated and may contain mistakes; the official description above is the record.
