# CVE-2021-23900: Uncaught Exception leading to Denial of Service in json-sanitizer

> Crafted input causes invalid JSON output or exceptions in the json-sanitizer library, potentially leading to denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Jan 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-8rf5-92jh-3vc9

## What is CVE-2021-23900?

CVE-2021-23900 is a high-severity denial of service vulnerability in n/a, published on 13 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OWASP json-sanitizer before 1.2.2 can output invalid JSON or throw an undeclared exception for crafted input. This may lead to denial of service if the application is not prepared to handle these situations.

## Which versions are affected by CVE-2021-23900?

2 open source packages ship an affected version, including com.mikesamuel:json-sanitizer. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.mikesamuel:json-sanitizer` | Maven | All versions | 1.2.2 |
| `com.mikesamuel:json-sanitizer` | Maven | All versions | 1.2.2 |

Products: Owasp Json-Sanitizer.

## How do I fix CVE-2021-23900?

Upgrade com.mikesamuel:json-sanitizer to 1.2.2 or later.

## Is CVE-2021-23900 being exploited?

There is no known exploitation of CVE-2021-23900 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-23899](https://insights.sbomify.com/CVE-2021-23899/): Arbitrary code injection in json-sanitizer (critical 9.8)
- [CVE-2020-13973](https://insights.sbomify.com/CVE-2020-13973/): Cross-site scripting in json-sanitizer (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-23900 and fix it if it is affected.

What it is: CVE-2021-23900 is a high-severity denial of service vulnerability in n/a, published on 13 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-23900 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.mikesamuel:json-sanitizer (Maven): affected all versions; fixed in 1.2.2
- com.mikesamuel:json-sanitizer (Maven): affected all versions; fixed in 1.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-23900/ (Markdown: https://insights.sbomify.com/CVE-2021-23900/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-23900
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-23900
- OSV: https://osv.dev/vulnerability/CVE-2021-23900

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-23900/
Summaries are generated and may contain mistakes; the official description above is the record.
