# CVE-2021-23926: XMLBeans XML Entity Expansion

> Attackers can cause denial of service via XML Entity Expansion attacks in Apache XMLBeans due to missing parser protections.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jan 2021
- **Updated:** 13 Feb 2025
- **Also known as:** CLSA-2026-1770595753, CLSA-2026-1778028243, DEBIAN-CVE-2021-23926, DLA-2693-1, GHSA-mw3r-pfmg-xp92, OESA-2021-1077, SUSE-SU-2022:3875-1, SUSE-SU-2022:3876-1, UBUNTU-CVE-2021-23926, openSUSE-SU-2024:12455-1

## What is CVE-2021-23926?

CVE-2021-23926 is a critical denial of service vulnerability in Debian Debian Linux, published on 14 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The XML parsers used by XMLBeans up to version 2.6.0 did not set the properties needed to protect the user from malicious XML input. Vulnerabilities include possibilities for XML Entity Expansion attacks. Affects XMLBeans up to and including v2.6.0.

Weakness: CWE-776 (Improper Restriction of Recursive Entity References in DTDs)

## Which versions are affected by CVE-2021-23926?

2 open source packages ship an affected version, including org.apache.xmlbeans:xmlbeans. It affects 7 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.xmlbeans:xmlbeans` | Maven | All versions | 3.0.0 |
| `org.apache.xmlbeans:xmlbeans` | Maven | All versions | 3.0.0 |
| `xmlbeans` | SUSE:Enterprise Storage 7 | All versions | 2.6.0-150000.5.3.1 |
| `xmlbeans` | SUSE:Linux Enterprise High Performance Computing 15 SP2-ESPOS | All versions | 2.6.0-150000.5.3.1 |
| `xmlbeans` | SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS | All versions | 2.6.0-150000.5.3.1 |
| `xmlbeans` | SUSE:Linux Enterprise Module for Basesystem 15 SP3 | All versions | 2.6.0-150000.5.3.1 |
| `xmlbeans` | SUSE:Linux Enterprise Module for Basesystem 15 SP4 | All versions | 2.6.0-150000.5.3.1 |
| `xmlbeans` | SUSE:Linux Enterprise Server 15 SP2-BCL | All versions | 2.6.0-150000.5.3.1 |
| `xmlbeans` | SUSE:Linux Enterprise Server 15 SP2-LTSS | All versions | 2.6.0-150000.5.3.1 |
| `xmlbeans` | SUSE:Linux Enterprise Server for SAP Applications 15 SP2 | All versions | 2.6.0-150000.5.3.1 |
| `xmlbeans` | SUSE:Linux Enterprise Software Development Kit 12 SP5 | All versions | 2.6.0-3.3.1 |
| `xmlbeans` | SUSE:Linux Enterprise Workstation Extension 12 SP5 | All versions | 2.6.0-3.3.1 |
| `xmlbeans` | SUSE:Manager Proxy 4.1 | All versions | 2.6.0-150000.5.3.1 |
| `xmlbeans` | SUSE:Manager Retail Branch Server 4.1 | All versions | 2.6.0-150000.5.3.1 |
| `xmlbeans` | SUSE:Manager Server 4.1 | All versions | 2.6.0-150000.5.3.1 |
| `xmlbeans` | openSUSE:Leap 15.3 | All versions | 2.6.0-150000.5.3.1 |
| `xmlbeans` | openSUSE:Leap 15.4 | All versions | 2.6.0-150000.5.3.1 |

Products: Apache Xmlbeans, Debian Debian Linux, Netapp Oncommand Unified Manager Core Package, Netapp Snap Creator Framework, Netapp Snapmanager, Oracle Middleware Common Libraries and Tools, Oracle Peoplesoft Enterprise Peopletools.

## How do I fix CVE-2021-23926?

Upgrade org.apache.xmlbeans:xmlbeans to 3.0.0 or later.

## Is CVE-2021-23926 being exploited?

There is no known exploitation of CVE-2021-23926 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-23926 and fix it if it is affected.

What it is: CVE-2021-23926 is a critical denial of service vulnerability in Debian Debian Linux, published on 14 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-23926 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.xmlbeans:xmlbeans (Maven): affected all versions; fixed in 3.0.0
- org.apache.xmlbeans:xmlbeans (Maven): affected all versions; fixed in 3.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-23926/ (Markdown: https://insights.sbomify.com/CVE-2021-23926/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-23926
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-23926
- OSV: https://osv.dev/vulnerability/CVE-2021-23926

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-23926/
Summaries are generated and may contain mistakes; the official description above is the record.
