CVE-2021-23937 DNS proxy and possible amplification attack
An attacker can trigger arbitrary DNS lookups via unsanitized headers, potentially causing denial of service or information disclosure in Apache Wicket applications.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-23937?
CVE-2021-23937 is a high-severity server-side request forgery vulnerability in Apache Wicket, published on 25 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A DNS proxy and possible amplification attack vulnerability in WebClientInfo of Apache Wicket allows an attacker to trigger arbitrary DNS lookups from the server when the X-Forwarded-For header is not properly sanitized. This DNS lookup can be engineered to overload an internal DNS server or to slow down request processing of the Apache Wicket application causing a possible denial of service on either the internal infrastructure or the web application itself. This issue affects Apache Wicket Apache Wicket 9.x version 9.2.0 and prior versions; Apache Wicket 8.x version 8.11.0 and prior versions; Apache Wicket 7.x version 7.17.0 and prior versions and Apache Wicket 6.x version 6.2.0 and later versions.
Weakness: CWE-200
Which versions are affected by CVE-2021-23937?
6 open source packages ship an affected version, including org.apache.wicket:wicket-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.wicket:wicket-core Maven | All versions | 7.18.0 |
org.apache.wicket:wicket-core Maven | All versions | 7.18.0 |
org.apache.wicket:wicket-core Maven | From 8.0.0 | 8.12.0 |
org.apache.wicket:wicket-core Maven | From 8.0.0 | 8.12.0 |
org.apache.wicket:wicket-core Maven | From 9.0.0 | 9.3.0 |
org.apache.wicket:wicket-core Maven | From 9.0.0 | 9.3.0 |
Products include Apache Wicket.
How do I fix CVE-2021-23937?
Upgrade org.apache.wicket:wicket-core to a fixed version for your release line: 7.18.0, 8.12.0 or 9.3.0.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2021-23937 being exploited?
There is no known exploitation of CVE-2021-23937 in the wild and no public exploit code.
Other vulnerabilities in Apache Wicket
- CVE-2024-36522 Apache Wicket: Remote code execution via XSLT injection
- CVE-2026-40010 Apache Wicket: possible session fixation using AuthenticatedWebSession
- CVE-2016-6793 Deserialization in n/a
- CVE-2016-6806 Apache Wicket vulnerable to CSRF attacks
- CVE-2026-71257 Apache Wicket: Configured file upload limits are not enforced when the multipart request has already been parsed
Sources
Also known as GHSA-hmhg-95wh-r699.