# CVE-2021-23937: DNS proxy and possible amplification attack

> An attacker can trigger arbitrary DNS lookups via unsanitized headers, potentially causing denial of service or information disclosure in Apache Wicket applications.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 May 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-hmhg-95wh-r699

## What is CVE-2021-23937?

CVE-2021-23937 is a high-severity server-side request forgery vulnerability in Apache Wicket, published on 25 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A DNS proxy and possible amplification attack vulnerability in WebClientInfo of Apache Wicket allows an attacker to trigger arbitrary DNS lookups from the server when the X-Forwarded-For header is not properly sanitized. This DNS lookup can be engineered to overload an internal DNS server or to slow down request processing of the Apache Wicket application causing a possible denial of service on either the internal infrastructure or the web application itself. This issue affects Apache Wicket Apache Wicket 9.x version 9.2.0 and prior versions; Apache Wicket 8.x version 8.11.0 and prior versions; Apache Wicket 7.x version 7.17.0 and prior versions and Apache Wicket 6.x version 6.2.0 and later versions.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2021-23937?

6 open source packages ship an affected version, including org.apache.wicket:wicket-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.wicket:wicket-core` | Maven | All versions | 7.18.0 |
| `org.apache.wicket:wicket-core` | Maven | All versions | 7.18.0 |
| `org.apache.wicket:wicket-core` | Maven | From 8.0.0 | 8.12.0 |
| `org.apache.wicket:wicket-core` | Maven | From 8.0.0 | 8.12.0 |
| `org.apache.wicket:wicket-core` | Maven | From 9.0.0 | 9.3.0 |
| `org.apache.wicket:wicket-core` | Maven | From 9.0.0 | 9.3.0 |

Products: Apache Wicket.

## How do I fix CVE-2021-23937?

Upgrade org.apache.wicket:wicket-core to a fixed version for your release line: 7.18.0, 8.12.0 or 9.3.0.

## Is CVE-2021-23937 being exploited?

There is no known exploitation of CVE-2021-23937 in the wild and no public exploit code.

## Other vulnerabilities in Apache Wicket

- [CVE-2024-36522](https://insights.sbomify.com/CVE-2024-36522/): Apache Wicket: Remote code execution via XSLT injection (critical 9.8)
- [CVE-2026-40010](https://insights.sbomify.com/CVE-2026-40010/): Apache Wicket: possible session fixation using AuthenticatedWebSession (critical 9.1)
- [CVE-2016-6793](https://insights.sbomify.com/CVE-2016-6793/): Deserialization in n/a (critical 9.1)
- [CVE-2016-6806](https://insights.sbomify.com/CVE-2016-6806/): Apache Wicket vulnerable to CSRF attacks (high 8.8)
- [CVE-2026-71257](https://insights.sbomify.com/CVE-2026-71257/): Apache Wicket: Configured file upload limits are not enforced when the multipart request has already been parsed (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-23937 and fix it if it is affected.

What it is: CVE-2021-23937 is a high-severity server-side request forgery vulnerability in Apache Wicket, published on 25 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-23937 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.wicket:wicket-core (Maven): affected all versions; fixed in 7.18.0
- org.apache.wicket:wicket-core (Maven): affected all versions; fixed in 7.18.0
- org.apache.wicket:wicket-core (Maven): affected from 8.0.0; fixed in 8.12.0
- org.apache.wicket:wicket-core (Maven): affected from 8.0.0; fixed in 8.12.0
- org.apache.wicket:wicket-core (Maven): affected from 9.0.0; fixed in 9.3.0
- org.apache.wicket:wicket-core (Maven): affected from 9.0.0; fixed in 9.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-23937/ (Markdown: https://insights.sbomify.com/CVE-2021-23937/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-23937
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-23937
- OSV: https://osv.dev/vulnerability/CVE-2021-23937

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-23937/
Summaries are generated and may contain mistakes; the official description above is the record.
