# CVE-2021-24044: Access of Resource Using Incompatible Type in Hermes

> A type confusion vulnerability in the Hermes JavaScript engine allows attackers to cause a segmentation fault and potentially execute arbitrary code.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jan 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-7mhc-prgv-r3q4

## What is CVE-2021-24044?

CVE-2021-24044 is a critical memory corruption vulnerability in Facebook Hermes, published on 15 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

By passing invalid javascript code where await and yield were called upon non-async and non-generator getter/setter functions, Hermes would invoke generator functions and error out on invalid await/yield positions. This could result in segmentation fault as a consequence of type confusion error, with a low chance of RCE. This issue affects Hermes versions prior to v0.10.0.

Weakness: CWE-843 (Access of Resource Using Incompatible Type)

## Which versions are affected by CVE-2021-24044?

2 open source packages ship an affected version, including hermes-engine. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hermes-engine` | npm | All versions | 0.10.0 |
| `hermes-engine` | npm | All versions | 0.10.0 |

Products: Facebook Hermes.

## How do I fix CVE-2021-24044?

Upgrade hermes-engine to 0.10.0 or later.

## Is CVE-2021-24044 being exploited?

There is no known exploitation of CVE-2021-24044 in the wild and no public exploit code.

## Other vulnerabilities in Facebook Hermes

- [CVE-2023-23556](https://insights.sbomify.com/CVE-2023-23556/): Memory corruption in Hermes (critical 9.8)
- [CVE-2023-23557](https://insights.sbomify.com/CVE-2023-23557/): Memory corruption in Hermes (critical 9.8)
- [CVE-2023-25933](https://insights.sbomify.com/CVE-2023-25933/): Memory corruption in Hermes (critical 9.8)
- [CVE-2023-28081](https://insights.sbomify.com/CVE-2023-28081/): Use after free in Hermes (critical 9.8)
- [CVE-2023-30470](https://insights.sbomify.com/CVE-2023-30470/): Use after free in Hermes (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-24044 and fix it if it is affected.

What it is: CVE-2021-24044 is a critical memory corruption vulnerability in Facebook Hermes, published on 15 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-24044 in the wild and no public exploit code.

Affected packages and fixed versions:
- hermes-engine (npm): affected all versions; fixed in 0.10.0
- hermes-engine (npm): affected all versions; fixed in 0.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-24044/ (Markdown: https://insights.sbomify.com/CVE-2021-24044/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-24044
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-24044
- OSV: https://osv.dev/vulnerability/CVE-2021-24044

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-24044/
Summaries are generated and may contain mistakes; the official description above is the record.
