# CVE-2021-24313: WP Prayer < 1.6.2 - Authenticated Stored Cross-Site Scripting (XSS)

> Authenticated users can inject malicious scripts via prayer request fields, potentially leading to code execution in the context of other users.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 1 Jun 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-77vm-hfph-f8g6

## What is CVE-2021-24313?

CVE-2021-24313 is a medium-severity cross-site scripting vulnerability in Unknown WP Prayer, published on 1 Jun 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

The WP Prayer WordPress plugin before 1.6.2 provides the functionality to store requested prayers/praises and list them on a WordPress website. These stored prayer/praise requests can be listed by using the WP Prayer engine. An authenticated WordPress user with any role can fill in the form to request a prayer. The form to request prayers or praises have several fields. The 'prayer request' and 'praise request' fields do not use proper input validation and can be used to store XSS payloads.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-24313?

It affects 1 product.


Products: Goprayer Wp Prayer.

## How do I fix CVE-2021-24313?

No fix has been published for CVE-2021-24313 yet. Limit exposure of the affected software until one is available.

## Is CVE-2021-24313 being exploited?

There is no known exploitation of CVE-2021-24313 in the wild and no public exploit code.

## Other vulnerabilities in Unknown WP Prayer

- [CVE-2024-3406](https://insights.sbomify.com/CVE-2024-3406/): WP Prayer <= 2.0.9 - Email Settings Update via CSRF (high 8.8)
- [CVE-2024-3405](https://insights.sbomify.com/CVE-2024-3405/): WP Prayer <= 2.0.9 - Settings Update via CSRF (high 7.6)
- [CVE-2023-25705](https://insights.sbomify.com/CVE-2023-25705/): WordPress WP Prayer Plugin <= 1.9.6 is vulnerable to Cross Site Scripting (XSS) (medium 5.9)
- [CVE-2024-3407](https://insights.sbomify.com/CVE-2024-3407/): WP Prayer <= 2.0.9 - Arbitrary Prayer Deletion via CSRF (medium 5.3)
- [CVE-2021-4412](https://insights.sbomify.com/CVE-2021-4412/): WP Prayer <= 1.6.5 - Cross-Site Request Forgery Bypass (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-24313 and fix it if it is affected.

What it is: CVE-2021-24313 is a medium-severity cross-site scripting vulnerability in Unknown WP Prayer, published on 1 Jun 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-24313 in the wild and no public exploit code.

Affected product: Unknown WP Prayer. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-24313/ (Markdown: https://insights.sbomify.com/CVE-2021-24313/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-24313
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-24313
- OSV: https://osv.dev/vulnerability/CVE-2021-24313

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-24313/
Summaries are generated and may contain mistakes; the official description above is the record.
