# CVE-2021-2432: Denial of service in Java SE JDK and JRE

> An unauthenticated attacker can cause a partial denial of service in Java SE via the JNDI component.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Jul 2021
- **Updated:** 25 Sep 2024
- **Also known as:** BIT-java-2021-2432, BIT-java-min-2021-2432, BIT-jre-2021-2432, GHSA-3xjg-p34v-7jgf

## What is CVE-2021-2432?

CVE-2021-2432 is a low-severity denial of service vulnerability in Mcafee Epolicy Orchestrator, published on 20 Jul 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vulnerability in the Java SE product of Oracle Java SE (component: JNDI). The supported version that is affected is Java SE: 7u301. Difficult to exploit vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Java SE. Successful attacks of this vulnerability can result in unauthorized ability to cause a partial denial of service (partial DOS) of Java SE. Note: This vulnerability applies to Java deployments, typically in clients running sandboxed Java Web Start applications or sandboxed Java applets, that load and run untrusted code (e.g., code that comes from the internet) and rely on the Java sandbox for security. This vulnerability can also be exploited by using APIs in the specified Component, e.g., through a web service which supplies data to the APIs. CVSS 3.1 Base Score 3.7 (Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L).

## Which versions are affected by CVE-2021-2432?

3 open source packages ship an affected version, including java, java-min and jre. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `java` | Bitnami | All versions | 1.7.0, 7.0.311 |
| `java-min` | Bitnami | All versions | 1.7.0, 7.0.311 |
| `jre` | Bitnami | All versions | 1.7.0, 7.0.311 |

Products: Mcafee Epolicy Orchestrator, Oracle Jdk.

## How do I fix CVE-2021-2432?

Upgrade java to a fixed version for your release line: 1.7.0 or 7.0.311.

## Is CVE-2021-2432 being exploited?

There is no known exploitation of CVE-2021-2432 in the wild and no public exploit code.

## Other vulnerabilities in Mcafee Epolicy Orchestrator

- [CVE-2016-8027](https://insights.sbomify.com/CVE-2016-8027/): SQL injection in McAfee ePolicy Orchestrator (ePO) 5.3.2 and earlier and 5.1.3 and earlier (critical 10.0)
- [CVE-2006-5156](https://insights.sbomify.com/CVE-2006-5156/): Memory corruption in n/a (critical 10.0)
- [CVE-2002-0690](https://insights.sbomify.com/CVE-2002-0690/): Code injection in n/a (critical 10.0)
- [CVE-2007-1498](https://insights.sbomify.com/CVE-2007-1498/): Memory corruption in n/a (critical 9.3)
- [CVE-2015-8765](https://insights.sbomify.com/CVE-2015-8765/): Deserialization in n/a (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-2432 and fix it if it is affected.

What it is: CVE-2021-2432 is a low-severity denial of service vulnerability in Mcafee Epolicy Orchestrator, published on 20 Jul 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-2432 in the wild and no public exploit code.

Affected packages and fixed versions:
- java (Bitnami): affected all versions; fixed in 1.7.0, 7.0.311
- java-min (Bitnami): affected all versions; fixed in 1.7.0, 7.0.311
- jre (Bitnami): affected all versions; fixed in 1.7.0, 7.0.311

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-2432/ (Markdown: https://insights.sbomify.com/CVE-2021-2432/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-2432
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-2432
- OSV: https://osv.dev/vulnerability/CVE-2021-2432

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-2432/
Summaries are generated and may contain mistakes; the official description above is the record.
