{"answers":{"affected":"2 open source packages ship an affected version, including woocommerce/woocommerce. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-24323 in the wild and no public exploit code.","fix":"Upgrade woocommerce/woocommerce to 5.2.0 or later.","what":"CVE-2021-24323 is a medium-severity cross-site scripting vulnerability in Automattic WooCommerce, published on 17 May 2021. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-24323 and fix it if it is affected.\n\nWhat it is: CVE-2021-24323 is a medium-severity cross-site scripting vulnerability in Automattic WooCommerce, published on 17 May 2021. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-24323 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- woocommerce/woocommerce (Packagist): affected all versions; fixed in 5.2.0\n- woocommerce/woocommerce (Packagist): affected all versions; fixed in 5.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-24323/ (Markdown: https://insights.sbomify.com/CVE-2021-24323/index.md)","id":"CVE-2021-24323","markdown":"https://insights.sbomify.com/CVE-2021-24323/index.md","name":"CVE-2021-24323","record":{"aliases":["GHSA-mp46-7x6q-f28m"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"WooCommerce plugin","requires_auth":"high_privilege","summary":"Authenticated administrators can inject malicious scripts via tax class fields in WooCommerce when taxes are enabled, leading to stored XSS.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"WPScan","cpe":[{"product":"woocommerce","vendor":"woocommerce"}],"cvss":{"score":4.8,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"When taxes are enabled, the \"Additional tax classes\" field was not properly sanitised or escaped before being output back in the admin dashboard, allowing high privilege users such as admin to use XSS payloads even when the unfiltered_html is disabled","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Woocommerce \u003c 5.2.0 - Authenticated Stored Cross-Site Scripting (XSS)","id":"CVE-2021-24323","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2021"},"n_packages":2,"n_references":1,"next":{"headline":"404 SEO Redirection \u003c= 1.3 - CSRF to Stored Cross-Site Scripting (XSS)","id":"CVE-2021-24324"},"packages":[{"ecosystem":"Packagist","fixed":["5.2.0"],"introduced":["0"],"last_affected":[],"package":"woocommerce/woocommerce","purl":null,"source":"GHSA-mp46-7x6q-f28m"},{"ecosystem":"Packagist","fixed":["5.2.0"],"introduced":["0"],"last_affected":[],"package":"woocommerce/woocommerce","purl":"pkg:composer/woocommerce/woocommerce","source":"GHSA-mp46-7x6q-f28m"}],"prev":{"headline":"Database Backup for WordPress \u003c 2.4 - Authenticated Persistent Cross-Site Scripting (XSS)","id":"CVE-2021-24322"},"products":["WooCommerce"],"published":"2021-05-17","related":[{"cvss_score":8.8,"headline":"WooCommerce Cross-Site Request Forgery (CSRF)","id":"CVE-2019-20891","kev_date_added":null,"published":"2020-06-19"},{"cvss_score":8.8,"headline":"Code injection in n/a","id":"CVE-2017-18356","kev_date_added":null,"published":"2019-01-15"},{"cvss_score":8.1,"headline":"Path traversal in n/a","id":"CVE-2018-20714","kev_date_added":null,"published":"2019-01-15"},{"cvss_score":6.1,"headline":"WooCommerce \u003c= 9.4.2 - PostMessage-Based Cross-Site Scripting","id":"CVE-2025-5062","kev_date_added":null,"published":"2025-05-22"},{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2019-9168","kev_date_added":null,"published":"2019-02-26"},{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2015-2329","kev_date_added":null,"published":"2018-02-08"},{"cvss_score":5.9,"headline":"WordPress Product page shipping calculator for WooCommerce Plugin \u003c= 1.3.25 is vulnerable to Cross Site Scripting (XSS)","id":"CVE-2023-32575","kev_date_added":null,"published":"2023-08-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Automattic"]},"summary":"Authenticated administrators can inject malicious scripts via tax class fields in WooCommerce when taxes are enabled, leading to stored XSS.","url":"https://insights.sbomify.com/CVE-2021-24323/"}