# CVE-2021-24374: Jetpack < 9.8 - Carousel Module Non-Published Page/Post Attachment Comment Leak

> Attackers can view comments on unpublished pages and posts via the Jetpack Carousel module, exposing private content.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Jun 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-5hr6-r8h6-wh22

## What is CVE-2021-24374?

CVE-2021-24374 is a medium-severity vulnerability in Automattic Jetpack – WP Security, Backup, Speed, & Growth, published on 21 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Jetpack Carousel module of the JetPack WordPress plugin before 9.8 allows users to create a "carousel" type image gallery and allows users to comment on the images. A security vulnerability was found within the Jetpack Carousel module by nguyenhg_vcs that allowed the comments of non-published page/posts to be leaked.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2021-24374?

2 open source packages ship an affected version, including automattic/jetpack. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `automattic/jetpack` | Packagist | All versions | 9.8 |
| `automattic/jetpack` | Packagist | All versions | 9.8 |

Products: Automattic Jetpack.

## How do I fix CVE-2021-24374?

Upgrade automattic/jetpack to 9.8 or later.

## Is CVE-2021-24374 being exploited?

There is no known exploitation of CVE-2021-24374 in the wild and no public exploit code.

## Other vulnerabilities in Automattic Jetpack – WP Security, Backup, Speed, & Growth

- [CVE-2023-2996](https://insights.sbomify.com/CVE-2023-2996/): Jetpack < 12.1.1 - Author+ Arbitrary File Manipulation via API (high 8.8)
- [CVE-2011-4673](https://insights.sbomify.com/CVE-2011-4673/): SQL injection in n/a (high 7.5)
- [CVE-2023-45050](https://insights.sbomify.com/CVE-2023-45050/): WordPress Jetpack Plugin <= 12.8-a.1 is vulnerable to Cross Site Scripting (XSS) (medium 6.5)
- [CVE-2024-4392](https://insights.sbomify.com/CVE-2024-4392/): Cross-site scripting in Jetpack – WP Security, Backup, Speed, & Growth (medium 6.4)
- [CVE-2024-10858](https://insights.sbomify.com/CVE-2024-10858/): Jetpack 13.0-14.0 - Unauthenticated DOM-XSS (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-24374 and fix it if it is affected.

What it is: CVE-2021-24374 is a medium-severity vulnerability in Automattic Jetpack – WP Security, Backup, Speed, & Growth, published on 21 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-24374 in the wild and no public exploit code.

Affected packages and fixed versions:
- automattic/jetpack (Packagist): affected all versions; fixed in 9.8
- automattic/jetpack (Packagist): affected all versions; fixed in 9.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-24374/ (Markdown: https://insights.sbomify.com/CVE-2021-24374/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-24374
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-24374
- OSV: https://osv.dev/vulnerability/CVE-2021-24374

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-24374/
Summaries are generated and may contain mistakes; the official description above is the record.
