# CVE-2021-24421: WP JobSearch < 1.7.4 - Authenticated Stored XSS

> Low-privilege users can inject JavaScript into the WP JobSearch plugin's resume page, leading to stored cross-site scripting attacks against other users.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 12 Jul 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-q4j4-vw28-779r

## What is CVE-2021-24421?

CVE-2021-24421 is a medium-severity cross-site scripting vulnerability in Unknown WP JobSearch, published on 12 Jul 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

The WP JobSearch WordPress plugin before 1.7.4 did not sanitise or escape multiple of its parameters from the my-resume page before outputting them in the page, allowing low privilege users to use JavaScript payloads in them and leading to a Stored Cross-Site Scripting issue

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-24421?

It affects 1 product.


Products: Eyecix Jobsearch Wp Job Board.

## How do I fix CVE-2021-24421?

No fix has been published for CVE-2021-24421 yet. Limit exposure of the affected software until one is available.

## Is CVE-2021-24421 being exploited?

There is no known exploitation of CVE-2021-24421 in the wild and no public exploit code.

## Other vulnerabilities in Unknown WP JobSearch

- [CVE-2024-8615](https://insights.sbomify.com/CVE-2024-8615/): WP JobSearch <= 2.6.7 - Unauthenticated Arbitrary File Upload (critical 10.0)
- [CVE-2024-8614](https://insights.sbomify.com/CVE-2024-8614/): WP JobSearch <= 2.6.7 - Authenticated (Subscriber+) Arbitrary File Upload (critical 9.9)
- [CVE-2024-47636](https://insights.sbomify.com/CVE-2024-47636/): WordPress WP JobSearch plugin <= 2.5.9 - PHP Object Injection vulnerability (critical 9.8)
- [CVE-2024-43931](https://insights.sbomify.com/CVE-2024-43931/): WordPress JobSearch WP Job Board WordPress Plugin plugin <= 2.5.3 - PHP Object Injection vulnerability (critical 9.8)
- [CVE-2021-4361](https://insights.sbomify.com/CVE-2021-4361/): JobSearch WP Job Board <= 1.8.1 - Missing Authorization to Arbitrary Options Update (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-24421 and fix it if it is affected.

What it is: CVE-2021-24421 is a medium-severity cross-site scripting vulnerability in Unknown WP JobSearch, published on 12 Jul 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-24421 in the wild and no public exploit code.

Affected product: Unknown WP JobSearch. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-24421/ (Markdown: https://insights.sbomify.com/CVE-2021-24421/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-24421
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-24421
- OSV: https://osv.dev/vulnerability/CVE-2021-24421

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-24421/
Summaries are generated and may contain mistakes; the official description above is the record.
