# CVE-2021-24765: Perfect Survey < 1.5.2 - Unauthenticated Stored Cross-Site Scripting

> Unauthenticated attackers can inject malicious scripts via the X-Forwarded-For header in the Perfect Survey plugin when IP anonymization is disabled.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 1 Feb 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-9f2f-rwp6-gw4q

## What is CVE-2021-24765?

CVE-2021-24765 is a medium-severity cross-site scripting vulnerability in n/a, published on 1 Feb 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The Perfect Survey WordPress plugin through 1.5.2 does not validate and escape the X-Forwarded-For header value before outputting it in the statistic page when the Anonymize IP setting of a survey is turned off, leading to a Stored Cross-Site Scripting issue

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-24765?

It affects 1 product.


Products: Getperfectsurvey Perfect Survey.

## How do I fix CVE-2021-24765?

No fix has been published for CVE-2021-24765 yet. Limit exposure of the affected software until one is available.

## Is CVE-2021-24765 being exploited?

There is no known exploitation of CVE-2021-24765 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-24762](https://insights.sbomify.com/CVE-2021-24762/): Perfect Survey < 1.5.2 - Unauthenticated SQL Injection (critical 9.8)
- [CVE-2021-24763](https://insights.sbomify.com/CVE-2021-24763/): Perfect Survey < 1.5.2 - Unauthorised AJAX Call to Stored XSS / Survey Settings Update (high 8.8)
- [CVE-2021-24764](https://insights.sbomify.com/CVE-2021-24764/): Perfect Survey < 1.5.2 - Reflected Cross-Site Scripting (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-24765 and fix it if it is affected.

What it is: CVE-2021-24765 is a medium-severity cross-site scripting vulnerability in n/a, published on 1 Feb 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-24765 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-24765/ (Markdown: https://insights.sbomify.com/CVE-2021-24765/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-24765
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-24765
- OSV: https://osv.dev/vulnerability/CVE-2021-24765

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-24765/
Summaries are generated and may contain mistakes; the official description above is the record.
