# CVE-2021-24998: Simple JWT Login < 3.3.0 - Insecure Password Creation

> Attackers can predict randomly generated passwords for new user accounts due to insecure random number generation, leading to potential account takeover.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 27 Dec 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-96g6-83p3-m784

## What is CVE-2021-24998?

CVE-2021-24998 is a high-severity vulnerability in Unknown Simple JWT Login, published on 27 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Simple JWT Login WordPress plugin before 3.3.0 can be used to create new WordPress user accounts with a randomly generated password. The password is generated using the str_shuffle  PHP function that "does not generate cryptographically secure values, and should not be used for cryptographic purposes" according to PHP's documentation.

Weakness: CWE-330 (Use of Insufficiently Random Values)

## Which versions are affected by CVE-2021-24998?

It affects 1 product.


Products: Simple Jwt Login Project Simple Jwt Login.

## How do I fix CVE-2021-24998?

No fix has been published for CVE-2021-24998 yet. Limit exposure of the affected software until one is available.

## Is CVE-2021-24998 being exploited?

There is no known exploitation of CVE-2021-24998 in the wild and no public exploit code.

## Other vulnerabilities in Unknown Simple JWT Login

- [CVE-2021-24804](https://insights.sbomify.com/CVE-2021-24804/): Simple JWT Login < 3.2.1 - Arbitrary Settings Update to Site Takeover via CSRF (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-24998 and fix it if it is affected.

What it is: CVE-2021-24998 is a high-severity vulnerability in Unknown Simple JWT Login, published on 27 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-24998 in the wild and no public exploit code.

Affected product: Unknown Simple JWT Login. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-24998/ (Markdown: https://insights.sbomify.com/CVE-2021-24998/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-24998
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-24998
- OSV: https://osv.dev/vulnerability/CVE-2021-24998

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-24998/
Summaries are generated and may contain mistakes; the official description above is the record.
