CVE-2021-25284 SaltStack Salt Cleartext Storage of Sensitive Information via cmdmod
Attackers with log access can view exposed credentials in SaltStack logs, requiring an upgrade to SaltStack Salt to mitigate.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-25284?
CVE-2021-25284 is a medium-severity vulnerability in Debian Debian Linux, published on 27 Feb 2021. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
An issue was discovered in through SaltStack Salt before 3002.5. salt.modules.cmdmod can log credentials to the info or error log level.
Which versions are affected by CVE-2021-25284?
19 open source packages ship an affected version, including salt. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
salt PyPI | All versions | 2015.8.10, 2015.8.13, 2016.3.4, 2016.3.6, 2016.3.8, 2016.11.3, 2016.11.5, 2016.11.10, 2017.7.8, 2019.2.0rc1, 2019.2.5, 2019.2.8, 3000.6, 3001.4, 3002.5 |
salt PyPI | All versions | 2015.8.13 |
salt PyPI | All versions | 2015.8.13 |
salt PyPI | From 2016.11.7 | 2016.11.10 |
salt PyPI | From 2016.11.7 | 2016.11.10 |
salt PyPI | From 2016.3.0 | 2016.11.5 |
13 more packages
salt PyPI | From 2016.3.0 | 2016.11.5 |
salt PyPI | From 2017.5.0 | 2017.7.8 |
salt PyPI | From 2017.5.0 | 2017.7.8 |
salt PyPI | From 2018.2.0 to 2018.3.5 | None |
salt PyPI | From 2018.2.0 to 2018.3.5 | None |
salt PyPI | From 2019.2.0 | 2019.2.8 |
salt PyPI | From 2019.2.0 | 2019.2.8 |
salt PyPI | From 3000 | 3000.7 |
salt PyPI | From 3000 | 3000.7 |
salt PyPI | From 3001 | 3001.5 |
salt PyPI | From 3001 | 3001.5 |
salt PyPI | From 3002 | 3002.3 |
salt PyPI | From 3002 | 3002.3 |
Products include Debian Debian Linux, Fedoraproject Fedora, Saltstack Salt.
How do I fix CVE-2021-25284?
Upgrade salt to a fixed version for your release line: 2015.8.10, 2015.8.13, 2016.3.4 or 2016.3.6.
Is CVE-2021-25284 being exploited?
There is no known exploitation of CVE-2021-25284 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as GHSA-r55w-xph5-xvx2, PYSEC-2021-53, UBUNTU-CVE-2021-25284.