# CVE-2021-25287: Out-of-bounds Read in Pillow

> An out-of-bounds read in Pillow's J2kDecode allows attackers to cause denial of service or disclose sensitive memory contents.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jun 2021
- **Updated:** 3 Aug 2024
- **Also known as:** ALPINE-CVE-2021-25287, BIT-pillow-2021-25287, DEBIAN-CVE-2021-25287, GHSA-77gc-v2xv-rvvh, PYSEC-2021-137, ROOT-APP-PYPI-CVE-2021-25287, UBUNTU-CVE-2021-25287

## What is CVE-2021-25287?

CVE-2021-25287 is a critical memory corruption vulnerability in Fedoraproject Fedora, published on 2 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in Pillow before 8.2.0. There is an out-of-bounds read in J2kDecode, in j2ku_graya_la.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2021-25287?

4 open source packages ship an affected version, including pillow. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pillow` | Bitnami | All versions | 8.2.0 |
| `pillow` | PyPI | All versions | 8.2.0 |
| `pillow` | PyPI | From 2.4.0 | 8.2.0 |
| `pillow` | PyPI | From 2.4.0 | 8.2.0 |

Products: Fedoraproject Fedora, Python Pillow.

## How do I fix CVE-2021-25287?

Upgrade pillow to 8.2.0 or later.

## Is CVE-2021-25287 being exploited?

There is no known exploitation of CVE-2021-25287 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-25287 and fix it if it is affected.

What it is: CVE-2021-25287 is a critical memory corruption vulnerability in Fedoraproject Fedora, published on 2 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-25287 in the wild and no public exploit code.

Affected packages and fixed versions:
- pillow (Bitnami): affected all versions; fixed in 8.2.0
- pillow (PyPI): affected all versions; fixed in 8.2.0
- pillow (PyPI): affected from 2.4.0; fixed in 8.2.0
- pillow (PyPI): affected from 2.4.0; fixed in 8.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-25287/ (Markdown: https://insights.sbomify.com/CVE-2021-25287/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-25287
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-25287
- OSV: https://osv.dev/vulnerability/CVE-2021-25287

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-25287/
Summaries are generated and may contain mistakes; the official description above is the record.
