CVE-2021-25313 Rancher: XSS on /v3/cluster/
Remote attackers can execute JavaScript via malicious links in Rancher, potentially leading to session hijacking or account takeover.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-25313?
CVE-2021-25313 is a high-severity cross-site scripting vulnerability in SUSE Rancher, published on 5 Mar 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
A Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Rancher allows remote attackers to execute JavaScript via malicious links. This issue affects: SUSE Rancher Rancher versions prior to 2.5.6.
Weakness: CWE-79
Which versions are affected by CVE-2021-25313?
6 open source packages ship an affected version, including github.com/rancher/rancher. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/rancher/rancher Go | All versions | 2.3.11 |
github.com/rancher/rancher Go | All versions | 2.3.11 |
github.com/rancher/rancher Go | From 2.4.0 | 2.4.14 |
github.com/rancher/rancher Go | From 2.4.0 | 2.4.14 |
github.com/rancher/rancher Go | From 2.5.0 | 2.5.6 |
github.com/rancher/rancher Go | From 2.5.0 | 2.5.6 |
Products include Suse Rancher.
How do I fix CVE-2021-25313?
Upgrade github.com/rancher/rancher to a fixed version for your release line: 2.3.11, 2.4.14 or 2.5.6.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2021-25313 being exploited?
There is no known exploitation of CVE-2021-25313 in the wild and no public exploit code.
Other vulnerabilities in SUSE Rancher
- CVE-2023-22647 Rancher vulnerable to Privilege Escalation via manipulation of Secrets
- CVE-2023-22651 Rancher Webhook is misconfigured during upgrade process
- CVE-2022-43757 Rancher: Exposure of sensitive fields
- CVE-2021-36782 Rancher: Plaintext storage and exposure of credentials in Rancher API and cluster.management.cattle.io object
- CVE-2021-36783 Rancher: Failure to properly sanitize credentials in cluster template answers
Sources
Also known as GHSA-6m8r-jh89-rq7h.