# CVE-2021-25313: Rancher: XSS on /v3/cluster/

> Remote attackers can execute JavaScript via malicious links in Rancher, potentially leading to session hijacking or account takeover.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Mar 2021
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-6m8r-jh89-rq7h

## What is CVE-2021-25313?

CVE-2021-25313 is a high-severity cross-site scripting vulnerability in SUSE Rancher, published on 5 Mar 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Rancher allows remote attackers to execute JavaScript via malicious links. This issue affects: SUSE Rancher Rancher versions prior to 2.5.6.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-25313?

6 open source packages ship an affected version, including github.com/rancher/rancher. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/rancher/rancher` | Go | All versions | 2.3.11 |
| `github.com/rancher/rancher` | Go | All versions | 2.3.11 |
| `github.com/rancher/rancher` | Go | From 2.4.0 | 2.4.14 |
| `github.com/rancher/rancher` | Go | From 2.4.0 | 2.4.14 |
| `github.com/rancher/rancher` | Go | From 2.5.0 | 2.5.6 |
| `github.com/rancher/rancher` | Go | From 2.5.0 | 2.5.6 |

Products: Suse Rancher.

## How do I fix CVE-2021-25313?

Upgrade github.com/rancher/rancher to a fixed version for your release line: 2.3.11, 2.4.14 or 2.5.6.

## Is CVE-2021-25313 being exploited?

There is no known exploitation of CVE-2021-25313 in the wild and no public exploit code.

## Other vulnerabilities in SUSE Rancher

- [CVE-2023-22647](https://insights.sbomify.com/CVE-2023-22647/): Rancher vulnerable to Privilege Escalation via manipulation of Secrets (critical 9.9)
- [CVE-2023-22651](https://insights.sbomify.com/CVE-2023-22651/): Rancher Webhook is misconfigured during upgrade process (critical 9.9)
- [CVE-2022-43757](https://insights.sbomify.com/CVE-2022-43757/): Rancher: Exposure of sensitive fields (critical 9.9)
- [CVE-2021-36782](https://insights.sbomify.com/CVE-2021-36782/): Rancher: Plaintext storage and exposure of credentials in Rancher API and cluster.management.cattle.io object (critical 9.9)
- [CVE-2021-36783](https://insights.sbomify.com/CVE-2021-36783/): Rancher: Failure to properly sanitize credentials in cluster template answers (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-25313 and fix it if it is affected.

What it is: CVE-2021-25313 is a high-severity cross-site scripting vulnerability in SUSE Rancher, published on 5 Mar 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-25313 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/rancher/rancher (Go): affected all versions; fixed in 2.3.11
- github.com/rancher/rancher (Go): affected all versions; fixed in 2.3.11
- github.com/rancher/rancher (Go): affected from 2.4.0; fixed in 2.4.14
- github.com/rancher/rancher (Go): affected from 2.4.0; fixed in 2.4.14
- github.com/rancher/rancher (Go): affected from 2.5.0; fixed in 2.5.6
- github.com/rancher/rancher (Go): affected from 2.5.0; fixed in 2.5.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-25313/ (Markdown: https://insights.sbomify.com/CVE-2021-25313/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-25313
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-25313
- OSV: https://osv.dev/vulnerability/CVE-2021-25313

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-25313/
Summaries are generated and may contain mistakes; the official description above is the record.
