# CVE-2021-25641: Dubbo Zookeeper does not check serialization id

> Remote attackers can force the use of unsafe deserializers like Kryo or FST to achieve code execution if these libraries are present in the classpath.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 May 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-v2rg-8cwr-75g8

## What is CVE-2021-25641?

CVE-2021-25641 is a critical unsafe deserialization vulnerability in Apache Dubbo, published on 29 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Each Apache Dubbo server will set a serialization id to tell the clients which serialization protocol it is working on. But for Dubbo versions before 2.7.8 or 2.6.9, an attacker can choose which serialization id the Provider will use by tampering with the byte preamble flags, aka, not following the server's instruction. This means that if a weak deserializer such as the Kryo and FST are somehow in code scope (e.g. if Kryo is somehow a part of a dependency), a remote unauthenticated attacker can tell the Provider to use the weak deserializer, and then proceed to exploit it.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2021-25641?

4 open source packages ship an affected version, including org.apache.dubbo:dubbo and com.alibaba:dubbo. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.dubbo:dubbo` | Maven | From 2.5.0 | 2.7.8 |
| `org.apache.dubbo:dubbo` | Maven | From 2.5.0 | 2.7.8 |
| `com.alibaba:dubbo` | Maven | From 2.5.0 | 2.6.9 |
| `com.alibaba:dubbo` | Maven | From 2.5.0 | 2.6.9 |

Products: Apache Dubbo.

## How do I fix CVE-2021-25641?

Upgrade org.apache.dubbo:dubbo to 2.7.8 or later.

## Is CVE-2021-25641 being exploited?

There is no known exploitation of CVE-2021-25641 in the wild and no public exploit code.

Public exploit code:

- Apache/Alibaba Dubbo <= 2.7.3 PoC Code for CVE-2021-25641 RCE via Deserialization of Untrusted Data; Affects Versions <= 2.7.6 With Different Gadgets (github_poc): https://github.com/Dor-Tumarkin/CVE-2021-25641-Proof-of-Concept
- A Exploit Tool For CVE-2021-25641. (github_poc): https://github.com/l0n3rs/CVE-2021-25641

## Other vulnerabilities in Apache Dubbo

- [CVE-2023-29234](https://insights.sbomify.com/CVE-2023-29234/): Bypass serialize checks in Apache Dubbo (critical 9.8)
- [CVE-2023-46279](https://insights.sbomify.com/CVE-2023-46279/): Apache Dubbo: Bypass deny serialize list check in Apache Dubbo (critical 9.8)
- [CVE-2021-32824](https://insights.sbomify.com/CVE-2021-32824/): Regular expression Denial of Service in MooTools (critical 9.8)
- [CVE-2022-39198](https://insights.sbomify.com/CVE-2022-39198/): Apache Dubbo Hession Deserialization Vulnerability Gadgets Bypass (critical 9.8)
- [CVE-2021-43297](https://insights.sbomify.com/CVE-2021-43297/): Dubbo Hessian cause RCE when parse error (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-25641 and fix it if it is affected.

What it is: CVE-2021-25641 is a critical unsafe deserialization vulnerability in Apache Dubbo, published on 29 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-25641 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.dubbo:dubbo (Maven): affected from 2.5.0; fixed in 2.7.8
- org.apache.dubbo:dubbo (Maven): affected from 2.5.0; fixed in 2.7.8
- com.alibaba:dubbo (Maven): affected from 2.5.0; fixed in 2.6.9
- com.alibaba:dubbo (Maven): affected from 2.5.0; fixed in 2.6.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-25641/ (Markdown: https://insights.sbomify.com/CVE-2021-25641/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-25641
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-25641
- OSV: https://osv.dev/vulnerability/CVE-2021-25641

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-25641/
Summaries are generated and may contain mistakes; the official description above is the record.
