# CVE-2021-25642: Apache Hadoop YARN remote code execution in ZKConfigurationStore of capacity scheduler

> An attacker with ZooKeeper access can execute arbitrary commands via unsafe deserialization in Hadoop YARN's optional ZKConfigurationStore.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Aug 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-rr2m-gffv-mgrj

## What is CVE-2021-25642?

CVE-2021-25642 is a high-severity unsafe deserialization vulnerability in Apache Hadoop, published on 25 Aug 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

ZKConfigurationStore which is optionally used by CapacityScheduler of Apache Hadoop YARN deserializes data obtained from ZooKeeper without validation. An attacker having access to ZooKeeper can run arbitrary commands as YARN user by exploiting this. Users should upgrade to Apache Hadoop 2.10.2, 3.2.4, 3.3.4 or later (containing YARN-11126) if ZKConfigurationStore is used.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2021-25642?

6 open source packages ship an affected version, including org.apache.hadoop:hadoop-yarn-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.hadoop:hadoop-yarn-server` | Maven | All versions | 2.10.2 |
| `org.apache.hadoop:hadoop-yarn-server` | Maven | All versions | 2.10.2 |
| `org.apache.hadoop:hadoop-yarn-server` | Maven | From 3.0.0 | 3.2.4 |
| `org.apache.hadoop:hadoop-yarn-server` | Maven | From 3.0.0 | 3.2.4 |
| `org.apache.hadoop:hadoop-yarn-server` | Maven | From 3.3.0 | 3.3.4 |
| `org.apache.hadoop:hadoop-yarn-server` | Maven | From 3.3.0 | 3.3.4 |

Products: Apache Hadoop.

## How do I fix CVE-2021-25642?

Upgrade org.apache.hadoop:hadoop-yarn-server to a fixed version for your release line: 2.10.2, 3.2.4 or 3.3.4.

## Is CVE-2021-25642 being exploited?

There is no known exploitation of CVE-2021-25642 in the wild and no public exploit code.

Public exploit code:

- CVE-2021-25642 (github_poc): https://github.com/safe3s/CVE-2021-25642

## Other vulnerabilities in Apache Hadoop

- [CVE-2022-25168](https://insights.sbomify.com/CVE-2022-25168/): Command injection in org.apache.hadoop.fs.FileUtil.unTarUsingTar (critical 9.8)
- [CVE-2021-37404](https://insights.sbomify.com/CVE-2021-37404/): Heap buffer overflow in libhdfs native library (critical 9.8)
- [CVE-2022-26612](https://insights.sbomify.com/CVE-2022-26612/): Arbitrary file write in FileUtil#unpackEntries on Windows (critical 9.8)
- [CVE-2019-17195](https://insights.sbomify.com/CVE-2019-17195/): Improper Check for Unusual or Exceptional Conditions in Connect2id Nimbus JOSE+JWT (critical 9.8)
- [CVE-2017-15718](https://insights.sbomify.com/CVE-2017-15718/): Exposure of Sensitive Information in Hadoop (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-25642 and fix it if it is affected.

What it is: CVE-2021-25642 is a high-severity unsafe deserialization vulnerability in Apache Hadoop, published on 25 Aug 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-25642 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.hadoop:hadoop-yarn-server (Maven): affected all versions; fixed in 2.10.2
- org.apache.hadoop:hadoop-yarn-server (Maven): affected all versions; fixed in 2.10.2
- org.apache.hadoop:hadoop-yarn-server (Maven): affected from 3.0.0; fixed in 3.2.4
- org.apache.hadoop:hadoop-yarn-server (Maven): affected from 3.0.0; fixed in 3.2.4
- org.apache.hadoop:hadoop-yarn-server (Maven): affected from 3.3.0; fixed in 3.3.4
- org.apache.hadoop:hadoop-yarn-server (Maven): affected from 3.3.0; fixed in 3.3.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-25642/ (Markdown: https://insights.sbomify.com/CVE-2021-25642/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-25642
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-25642
- OSV: https://osv.dev/vulnerability/CVE-2021-25642

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-25642/
Summaries are generated and may contain mistakes; the official description above is the record.
