# CVE-2021-25738: Code exec via yaml parsing

> Attackers can execute arbitrary code by supplying malicious YAML to the Kubernetes Java Client library.

- **Severity:** Medium 6.7 (`CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Oct 2021
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-m8wh-mqgf-rr8g

## What is CVE-2021-25738?

CVE-2021-25738 is a medium-severity unsafe deserialization vulnerability in Kubernetes Java Client, published on 11 Oct 2021. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Loading specially-crafted yaml with the Kubernetes Java Client library can lead to code execution.

Weakness: CWE-502 (Deserialization of Untrusted Data), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2021-25738?

2 open source packages ship an affected version, including io.kubernetes:client-java. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.kubernetes:client-java` | Maven | All versions | 11.0.1 |
| `io.kubernetes:client-java` | Maven | All versions | 11.0.1 |

Products: Kubernetes Java.

## How do I fix CVE-2021-25738?

Upgrade io.kubernetes:client-java to 11.0.1 or later.

## Is CVE-2021-25738 being exploited?

There is no known exploitation of CVE-2021-25738 in the wild and no public exploit code.

## Other vulnerabilities in Kubernetes Java Client

- [CVE-2020-8570](https://insights.sbomify.com/CVE-2020-8570/): Kubernetes Java client libraries unvalidated path traversal in Copy implementation (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-25738 and fix it if it is affected.

What it is: CVE-2021-25738 is a medium-severity unsafe deserialization vulnerability in Kubernetes Java Client, published on 11 Oct 2021. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-25738 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.kubernetes:client-java (Maven): affected all versions; fixed in 11.0.1
- io.kubernetes:client-java (Maven): affected all versions; fixed in 11.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-25738/ (Markdown: https://insights.sbomify.com/CVE-2021-25738/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-25738
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-25738
- OSV: https://osv.dev/vulnerability/CVE-2021-25738

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-25738/
Summaries are generated and may contain mistakes; the official description above is the record.
