CVE-2021-25900 Buffer overflow in SmallVec::insert_many
A heap-based buffer overflow in the Rust smallvec crate allows attackers to execute arbitrary code or cause denial of service.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-25900?
CVE-2021-25900 is a critical memory corruption vulnerability in n/a, published on 22 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in the smallvec crate before 0.6.14 and 1.x before 1.6.1 for Rust. There is a heap-based buffer overflow in SmallVec::insert_many.
Weakness: CWE-787
Which versions are affected by CVE-2021-25900?
5 open source packages ship an affected version, including smallvec. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
smallvec crates.io | From 0.6.3 | 0.6.14, 1.6.1 |
smallvec crates.io | From 0.6.3 | 0.6.14 |
smallvec crates.io | From 0.6.3 | 0.6.14 |
smallvec crates.io | From 1.0.0 | 1.6.1 |
smallvec crates.io | From 1.0.0 | 1.6.1 |
Linux distribution packages (3)
librsvg SUSE:Linux Enterprise Module for Basesystem 15 SP2 | All versions | 2.46.5-3.3.1 |
librsvg SUSE:Linux Enterprise Module for Desktop Applications 15 SP2 | All versions | 2.46.5-3.3.1 |
librsvg openSUSE:Leap 15.2 | All versions | 2.46.5-lp152.2.3.1 |
Products include Servo Smallvec.
How do I fix CVE-2021-25900?
Upgrade smallvec to a fixed version for your release line: 0.6.14 or 1.6.1.
Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.
Is CVE-2021-25900 being exploited?
There is no known exploitation of CVE-2021-25900 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as DEBIAN-CVE-2021-25900, GHSA-43w2-9j62-hq99, MGASA-2021-0234, ROOT-APP-CARGO-CVE-2021-25900, RUSTSEC-2021-0003, SUSE-SU-2021:1408-1 and 3 more.