# CVE-2021-25916: Prototype pollution vulnerability in 'patchmerge'

> Prototype pollution in patchmerge allows attackers to cause denial of service and potentially execute remote code.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Mar 2021
- **Updated:** 30 Apr 2025
- **Also known as:** GHSA-84g3-cv89-m9gm

## What is CVE-2021-25916?

CVE-2021-25916 is a critical code injection vulnerability in patchmerge, published on 16 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Prototype pollution vulnerability in 'patchmerge' versions 1.0.0 through 1.0.1 allows an attacker to cause a denial of service and may lead to remote code execution.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2021-25916?

2 open source packages ship an affected version, including patchmerge. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `patchmerge` | npm | From 1.0.0 | 1.0.2 |
| `patchmerge` | npm | From 1.0.0 | 1.0.2 |

Products: Patchmerge Project Patchmerge.

## How do I fix CVE-2021-25916?

Upgrade patchmerge to 1.0.2 or later.

## Is CVE-2021-25916 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-25916 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-25916 and fix it if it is affected.

What it is: CVE-2021-25916 is a critical code injection vulnerability in patchmerge, published on 16 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-25916 exists.

Affected packages and fixed versions:
- patchmerge (npm): affected from 1.0.0; fixed in 1.0.2
- patchmerge (npm): affected from 1.0.0; fixed in 1.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-25916/ (Markdown: https://insights.sbomify.com/CVE-2021-25916/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-25916
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-25916
- OSV: https://osv.dev/vulnerability/CVE-2021-25916

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-25916/
Summaries are generated and may contain mistakes; the official description above is the record.
