# CVE-2021-25930: Cross-Site Request Forgery in OpenNMS Horizon

> Attackers can exploit CSRF to overwrite user privileges and delete users in OpenNMS Horizon and Meridian by renaming accounts without validation.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 May 2021
- **Updated:** 30 Apr 2025
- **Also known as:** GHSA-p63h-7hw8-5cw4

## What is CVE-2021-25930?

CVE-2021-25930 is a medium-severity vulnerability in OpenNMS, published on 20 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In OpenNMS Horizon, versions opennms-1-0-stable through opennms-27.1.0-1; OpenNMS Meridian, versions meridian-foundation-2015.1.0-1 through meridian-foundation-2019.1.18-1; meridian-foundation-2020.1.0-1 through meridian-foundation-2020.1.6-1 are vulnerable to CSRF, due to no CSRF protection, and since there is no validation of an existing user name while renaming a user. As a result, privileges of the renamed user are being overwritten by the old user and the old user is being deleted from the user list.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2021-25930?

4 open source packages ship an affected version, including org.opennms:opennms and org.opennms:opennms-config. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.opennms:opennms` | Maven | From 1.0.0 | 27.1.1 |
| `org.opennms:opennms` | Maven | From 1.0.0 | 27.1.1 |
| `org.opennms:opennms-config` | Maven | From 1.0.0 | 27.1.1 |
| `org.opennms:opennms-config` | Maven | From 1.0.0 | 27.1.1 |

Products: Opennms Horizon, Opennms Meridian.

## How do I fix CVE-2021-25930?

Upgrade org.opennms:opennms to 27.1.1 or later.

## Is CVE-2021-25930 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-25930 exists.

## Other vulnerabilities in OpenNMS

- [CVE-2021-25931](https://insights.sbomify.com/CVE-2021-25931/): Cross-Site Request Forgery in OpenNMS Horizon (high 8.8)
- [CVE-2021-3396](https://insights.sbomify.com/CVE-2021-3396/): OpenNMS Horizon RCE via JEXL2 expression (high 8.8)
- [CVE-2023-0872](https://insights.sbomify.com/CVE-2023-0872/): ROLE_REST can be used to escalate to ROLE_ADMIN via /rest/users (high 8.2)
- [CVE-2023-0870](https://insights.sbomify.com/CVE-2023-0870/): Form Can Be Manipulated with Cross-Site Request Forgery (CSRF) (high 8.1)
- [CVE-2020-11886](https://insights.sbomify.com/CVE-2020-11886/): SQL injection in n/a (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-25930 and fix it if it is affected.

What it is: CVE-2021-25930 is a medium-severity vulnerability in OpenNMS, published on 20 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-25930 exists.

Affected packages and fixed versions:
- org.opennms:opennms (Maven): affected from 1.0.0; fixed in 27.1.1
- org.opennms:opennms (Maven): affected from 1.0.0; fixed in 27.1.1
- org.opennms:opennms-config (Maven): affected from 1.0.0; fixed in 27.1.1
- org.opennms:opennms-config (Maven): affected from 1.0.0; fixed in 27.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-25930/ (Markdown: https://insights.sbomify.com/CVE-2021-25930/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-25930
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-25930
- OSV: https://osv.dev/vulnerability/CVE-2021-25930

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-25930/
Summaries are generated and may contain mistakes; the official description above is the record.
