CVE-2021-25931 Cross-Site Request Forgery in OpenNMS Horizon
An attacker can trick an admin into granting administrator privileges to a normal user via a CSRF vulnerability in OpenNMS.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-25931?
CVE-2021-25931 is a high-severity vulnerability in OpenNMS, published on 20 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
In OpenNMS Horizon, versions opennms-1-0-stable through opennms-27.1.0-1; OpenNMS Meridian, versions meridian-foundation-2015.1.0-1 through meridian-foundation-2019.1.18-1; meridian-foundation-2020.1.0-1 through meridian-foundation-2020.1.6-1 are vulnerable to CSRF, due to no CSRF protection at `/opennms/admin/userGroupView/users/updateUser`. This flaw allows assigning `ROLE_ADMIN` security role to a normal user. Using this flaw, an attacker can trick the admin user to assign administrator privileges to a normal user by enticing him to click upon an attacker-controlled website.
Weakness: CWE-352
Which versions are affected by CVE-2021-25931?
2 open source packages ship an affected version, including org.opennms:opennms. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
org.opennms:opennms Maven | From 1.0.0 | 27.1.1 |
org.opennms:opennms Maven | From 1.0.0 | 27.1.1 |
Products include Opennms Horizon, Opennms Meridian.
How do I fix CVE-2021-25931?
Upgrade org.opennms:opennms to 27.1.1 or later.
Is CVE-2021-25931 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-25931 exists.
Other vulnerabilities in OpenNMS
- CVE-2021-3396 OpenNMS Horizon RCE via JEXL2 expression
- CVE-2023-0872 ROLE_REST can be used to escalate to ROLE_ADMIN via /rest/users
- CVE-2023-0870 Form Can Be Manipulated with Cross-Site Request Forgery (CSRF)
- CVE-2020-11886 SQL injection in n/a
- CVE-2023-40313 Disable BeanShell Interpreter Remote Server Mode
Sources
Also known as GHSA-2rq5-68hm-h4j8.