{"answers":{"affected":"2 open source packages ship an affected version, including org.opennms:opennms. It affects 2 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-25931 exists.","fix":"Upgrade org.opennms:opennms to 27.1.1 or later.","what":"CVE-2021-25931 is a high-severity vulnerability in OpenNMS, published on 20 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-25931 and fix it if it is affected.\n\nWhat it is: CVE-2021-25931 is a high-severity vulnerability in OpenNMS, published on 20 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-25931 exists.\n\nAffected packages and fixed versions:\n- org.opennms:opennms (Maven): affected from 1.0.0; fixed in 27.1.1\n- org.opennms:opennms (Maven): affected from 1.0.0; fixed in 27.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-25931/ (Markdown: https://insights.sbomify.com/CVE-2021-25931/index.md)","id":"CVE-2021-25931","markdown":"https://insights.sbomify.com/CVE-2021-25931/index.md","name":"CVE-2021-25931","record":{"aliases":["GHSA-2rq5-68hm-h4j8"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenNMS monitoring","requires_auth":"none","summary":"An attacker can trick an admin into granting administrator privileges to a normal user via a CSRF vulnerability in OpenNMS.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Mend","cpe":[{"product":"horizon","vendor":"opennms"},{"product":"meridian","vendor":"opennms"}],"cvss":{"score":8.8,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"In OpenNMS Horizon, versions opennms-1-0-stable through opennms-27.1.0-1; OpenNMS Meridian, versions meridian-foundation-2015.1.0-1 through meridian-foundation-2019.1.18-1; meridian-foundation-2020.1.0-1 through meridian-foundation-2020.1.6-1 are vulnerable to CSRF, due to no CSRF protection at `/opennms/admin/userGroupView/users/updateUser`. This flaw allows assigning `ROLE_ADMIN` security role to a normal user. Using this flaw, an attacker can trick the admin user to assign administrator privileges to a normal user by enticing him to click upon an attacker-controlled website.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Cross-Site Request Forgery in OpenNMS Horizon","id":"CVE-2021-25931","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"csrf","year":"2021"},"n_packages":2,"n_references":3,"next":{"headline":"Cross-site scripting in OpenNMS","id":"CVE-2021-25932"},"packages":[{"ecosystem":"Maven","fixed":["27.1.1"],"introduced":["1.0.0"],"last_affected":[],"package":"org.opennms:opennms","purl":null,"source":"GHSA-2rq5-68hm-h4j8"},{"ecosystem":"Maven","fixed":["27.1.1"],"introduced":["1.0.0"],"last_affected":[],"package":"org.opennms:opennms","purl":"pkg:maven/org.opennms/opennms","source":"GHSA-2rq5-68hm-h4j8"}],"prev":{"headline":"Cross-Site Request Forgery in OpenNMS Horizon","id":"CVE-2021-25930"},"products":["OpenNMS"],"published":"2021-05-20","related":[{"cvss_score":8.8,"headline":"OpenNMS Horizon RCE via JEXL2 expression","id":"CVE-2021-3396","kev_date_added":null,"published":"2021-02-17"},{"cvss_score":8.2,"headline":"ROLE_REST can be used to escalate to ROLE_ADMIN via /rest/users","id":"CVE-2023-0872","kev_date_added":null,"published":"2023-08-14"},{"cvss_score":8.1,"headline":"Form Can Be Manipulated with Cross-Site Request Forgery (CSRF)","id":"CVE-2023-0870","kev_date_added":null,"published":"2023-03-22"},{"cvss_score":8.1,"headline":"SQL injection in n/a","id":"CVE-2020-11886","kev_date_added":null,"published":"2020-04-17"},{"cvss_score":7.1,"headline":"Disable BeanShell Interpreter Remote Server Mode","id":"CVE-2023-40313","kev_date_added":null,"published":"2023-08-17"},{"cvss_score":6.8,"headline":"Plaintext Password Present in the Web logs","id":"CVE-2023-0815","kev_date_added":null,"published":"2023-02-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-30","vendors":["n/a"]},"summary":"An attacker can trick an admin into granting administrator privileges to a normal user via a CSRF vulnerability in OpenNMS.","url":"https://insights.sbomify.com/CVE-2021-25931/"}