# CVE-2021-25931: Cross-Site Request Forgery in OpenNMS Horizon

> An attacker can trick an admin into granting administrator privileges to a normal user via a CSRF vulnerability in OpenNMS.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 May 2021
- **Updated:** 30 Apr 2025
- **Also known as:** GHSA-2rq5-68hm-h4j8

## What is CVE-2021-25931?

CVE-2021-25931 is a high-severity vulnerability in OpenNMS, published on 20 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In OpenNMS Horizon, versions opennms-1-0-stable through opennms-27.1.0-1; OpenNMS Meridian, versions meridian-foundation-2015.1.0-1 through meridian-foundation-2019.1.18-1; meridian-foundation-2020.1.0-1 through meridian-foundation-2020.1.6-1 are vulnerable to CSRF, due to no CSRF protection at `/opennms/admin/userGroupView/users/updateUser`. This flaw allows assigning `ROLE_ADMIN` security role to a normal user. Using this flaw, an attacker can trick the admin user to assign administrator privileges to a normal user by enticing him to click upon an attacker-controlled website.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2021-25931?

2 open source packages ship an affected version, including org.opennms:opennms. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.opennms:opennms` | Maven | From 1.0.0 | 27.1.1 |
| `org.opennms:opennms` | Maven | From 1.0.0 | 27.1.1 |

Products: Opennms Horizon, Opennms Meridian.

## How do I fix CVE-2021-25931?

Upgrade org.opennms:opennms to 27.1.1 or later.

## Is CVE-2021-25931 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-25931 exists.

## Other vulnerabilities in OpenNMS

- [CVE-2021-3396](https://insights.sbomify.com/CVE-2021-3396/): OpenNMS Horizon RCE via JEXL2 expression (high 8.8)
- [CVE-2023-0872](https://insights.sbomify.com/CVE-2023-0872/): ROLE_REST can be used to escalate to ROLE_ADMIN via /rest/users (high 8.2)
- [CVE-2023-0870](https://insights.sbomify.com/CVE-2023-0870/): Form Can Be Manipulated with Cross-Site Request Forgery (CSRF) (high 8.1)
- [CVE-2020-11886](https://insights.sbomify.com/CVE-2020-11886/): SQL injection in n/a (high 8.1)
- [CVE-2023-40313](https://insights.sbomify.com/CVE-2023-40313/): Disable BeanShell Interpreter Remote Server Mode (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-25931 and fix it if it is affected.

What it is: CVE-2021-25931 is a high-severity vulnerability in OpenNMS, published on 20 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-25931 exists.

Affected packages and fixed versions:
- org.opennms:opennms (Maven): affected from 1.0.0; fixed in 27.1.1
- org.opennms:opennms (Maven): affected from 1.0.0; fixed in 27.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-25931/ (Markdown: https://insights.sbomify.com/CVE-2021-25931/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-25931
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-25931
- OSV: https://osv.dev/vulnerability/CVE-2021-25931

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-25931/
Summaries are generated and may contain mistakes; the official description above is the record.
