CVE-2021-25940 ArangoDB - Insufficient Session Expiration after Password Change

High 8.8 Published Updated

Attackers retain access after password changes due to insufficient session expiration, allowing unauthorized actions in ArangoDB.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-25940?

CVE-2021-25940 is a high-severity authentication bypass vulnerability in arangodb, published on 16 Nov 2021. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

In ArangoDB, versions v3.7.6 through v3.8.3 are vulnerable to Insufficient Session Expiration. When a user’s password is changed by the administrator, the session isn’t invalidated, allowing a malicious user to still be logged in and perform arbitrary actions within the system.

Weakness: CWE-613

Which versions are affected by CVE-2021-25940?

1 open source package ship an affected version, including arangodb. It affects 1 product.

PackageAffectedFixed in
arangodb BitnamiFrom 3.7.63.8.4

Products include Arangodb Arangodb.

How do I fix CVE-2021-25940?

Upgrade arangodb to 3.8.4 or later.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2021-25940 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-25940 exists.

Sources

Also known as BIT-arangodb-2021-25940, GHSA-p437-2c77-84p4.

Is CVE-2021-25940 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free