{"answers":{"affected":"1 open source package ship an affected version, including arangodb. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-25940 exists.","fix":"Upgrade arangodb to 3.8.4 or later.","what":"CVE-2021-25940 is a high-severity authentication bypass vulnerability in arangodb, published on 16 Nov 2021. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-25940 and fix it if it is affected.\n\nWhat it is: CVE-2021-25940 is a high-severity authentication bypass vulnerability in arangodb, published on 16 Nov 2021. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-25940 exists.\n\nAffected packages and fixed versions:\n- arangodb (Bitnami): affected from 3.7.6; fixed in 3.8.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-25940/ (Markdown: https://insights.sbomify.com/CVE-2021-25940/index.md)","id":"CVE-2021-25940","markdown":"https://insights.sbomify.com/CVE-2021-25940/index.md","name":"CVE-2021-25940","record":{"aliases":["BIT-arangodb-2021-25940","GHSA-p437-2c77-84p4"],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"ArangoDB database","requires_auth":"low_privilege","summary":"Attackers retain access after password changes due to insufficient session expiration, allowing unauthorized actions in ArangoDB.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Mend","cpe":[{"product":"arangodb","vendor":"arangodb"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-613","name":"DEPRECATED: Insufficient Session Expiration"}],"description":"In ArangoDB, versions v3.7.6 through v3.8.3 are vulnerable to Insufficient Session Expiration. When a user’s password is changed by the administrator, the session isn’t invalidated, allowing a malicious user to still be logged in and perform arbitrary actions within the system.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"ArangoDB - Insufficient Session Expiration after Password Change","id":"CVE-2021-25940","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"auth_bypass","year":"2021"},"n_packages":1,"n_references":2,"next":{"headline":"Prototype Pollution in deep-override","id":"CVE-2021-25941"},"packages":[{"ecosystem":"Bitnami","fixed":["3.8.4"],"introduced":["3.7.6"],"last_affected":[],"package":"arangodb","purl":"pkg:bitnami/arangodb","source":"BIT-arangodb-2021-25940"}],"prev":{"headline":"ArangoDB - Blind SSRF when Downloading Foxx Service from URL","id":"CVE-2021-25939"},"products":["arangodb"],"published":"2021-11-16","related":[{"cvss_score":6.1,"headline":"Cross-site scripting in ArangoDB","id":"CVE-2021-25938","kev_date_added":null,"published":"2021-05-24"},{"cvss_score":2.7,"headline":"ArangoDB - Blind SSRF when Downloading Foxx Service from URL","id":"CVE-2021-25939","kev_date_added":null,"published":"2022-02-09"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-30","vendors":["arangodb"]},"summary":"Attackers retain access after password changes due to insufficient session expiration, allowing unauthorized actions in ArangoDB.","url":"https://insights.sbomify.com/CVE-2021-25940/"}