# CVE-2021-25940: ArangoDB - Insufficient Session Expiration after Password Change

> Attackers retain access after password changes due to insufficient session expiration, allowing unauthorized actions in ArangoDB.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Nov 2021
- **Updated:** 30 Apr 2025
- **Also known as:** BIT-arangodb-2021-25940, GHSA-p437-2c77-84p4

## What is CVE-2021-25940?

CVE-2021-25940 is a high-severity authentication bypass vulnerability in arangodb, published on 16 Nov 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In ArangoDB, versions v3.7.6 through v3.8.3 are vulnerable to Insufficient Session Expiration. When a user’s password is changed by the administrator, the session isn’t invalidated, allowing a malicious user to still be logged in and perform arbitrary actions within the system.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2021-25940?

1 open source package ship an affected version, including arangodb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `arangodb` | Bitnami | From 3.7.6 | 3.8.4 |

Products: Arangodb Arangodb.

## How do I fix CVE-2021-25940?

Upgrade arangodb to 3.8.4 or later.

## Is CVE-2021-25940 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-25940 exists.

## Other vulnerabilities in arangodb

- [CVE-2021-25938](https://insights.sbomify.com/CVE-2021-25938/): Cross-site scripting in ArangoDB (medium 6.1)
- [CVE-2021-25939](https://insights.sbomify.com/CVE-2021-25939/): ArangoDB - Blind SSRF when Downloading Foxx Service from URL (low 2.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-25940 and fix it if it is affected.

What it is: CVE-2021-25940 is a high-severity authentication bypass vulnerability in arangodb, published on 16 Nov 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-25940 exists.

Affected packages and fixed versions:
- arangodb (Bitnami): affected from 3.7.6; fixed in 3.8.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-25940/ (Markdown: https://insights.sbomify.com/CVE-2021-25940/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-25940
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-25940
- OSV: https://osv.dev/vulnerability/CVE-2021-25940

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-25940/
Summaries are generated and may contain mistakes; the official description above is the record.
