{"answers":{"affected":"2 open source packages ship an affected version, including deep-override. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-25941 exists.","fix":"Upgrade deep-override to 1.0.2 or later.","what":"CVE-2021-25941 is a critical code injection vulnerability in deep-override, published on 14 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-25941 and fix it if it is affected.\n\nWhat it is: CVE-2021-25941 is a critical code injection vulnerability in deep-override, published on 14 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-25941 exists.\n\nAffected packages and fixed versions:\n- deep-override (npm): affected from 1.0.0; fixed in 1.0.2\n- deep-override (npm): affected from 1.0.0; fixed in 1.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-25941/ (Markdown: https://insights.sbomify.com/CVE-2021-25941/index.md)","id":"CVE-2021-25941","markdown":"https://insights.sbomify.com/CVE-2021-25941/index.md","name":"CVE-2021-25941","record":{"aliases":["GHSA-v659-54cx-g4qr"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"npm deep-override library","requires_auth":"none","summary":"Prototype pollution in deep-override allows attackers to cause denial of service and potentially execute remote code.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Mend","cpe":[{"product":"deep-override","vendor":"deep-override_project"}],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-1321","name":"Improperly Controlled Modification of Object Prototype Attributes"}],"description":"Prototype pollution vulnerability in 'deep-override' versions 1.0.0 through 1.0.1 allows an attacker to cause a denial of service and may lead to remote code execution.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Prototype Pollution in deep-override","id":"CVE-2021-25941","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2021"},"n_packages":2,"n_references":2,"next":{"headline":"Prototype pollution in 101","id":"CVE-2021-25943"},"packages":[{"ecosystem":"npm","fixed":["1.0.2"],"introduced":["1.0.0"],"last_affected":[],"package":"deep-override","purl":null,"source":"GHSA-v659-54cx-g4qr"},{"ecosystem":"npm","fixed":["1.0.2"],"introduced":["1.0.0"],"last_affected":[],"package":"deep-override","purl":"pkg:npm/deep-override","source":"GHSA-v659-54cx-g4qr"}],"prev":{"headline":"ArangoDB - Insufficient Session Expiration after Password Change","id":"CVE-2021-25940"},"products":["deep-override"],"published":"2021-05-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-30","vendors":["n/a"]},"summary":"Prototype pollution in deep-override allows attackers to cause denial of service and potentially execute remote code.","url":"https://insights.sbomify.com/CVE-2021-25941/"}