# CVE-2021-25954: Improper Access Control in “Dolibarr”

> A low-privileged attacker can modify private notes in Dolibarr, bypassing administrative restrictions on the adherents note endpoint.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Aug 2021
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-vxhc-c4qm-647p, UBUNTU-CVE-2021-25954

## What is CVE-2021-25954?

CVE-2021-25954 is a medium-severity missing authorization vulnerability in dolibarr, published on 9 Aug 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In “Dolibarr” application, 2.8.1 to 13.0.4 don’t restrict or incorrectly restricts access to a resource from an unauthorized actor. A low privileged attacker can modify the Private Note which only an administrator has rights to do, the affected field is at “/adherents/note.php?id=1” endpoint.

Weakness: CWE-863 (Incorrect Authorization), CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2021-25954?

2 open source packages ship an affected version, including dolibarr/dolibarr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dolibarr/dolibarr` | Packagist | From 2.8.1 | 14.0.0 |
| `dolibarr/dolibarr` | Packagist | From 2.8.1 | 14.0.0 |

Products: Dolibarr Dolibarr.

## How do I fix CVE-2021-25954?

Upgrade dolibarr/dolibarr to 14.0.0 or later.

## Is CVE-2021-25954 being exploited?

There is no known exploitation of CVE-2021-25954 in the wild and no public exploit code.

## Other vulnerabilities in dolibarr

- [CVE-2019-19212](https://insights.sbomify.com/CVE-2019-19212/): Dolibarr Cross-site Scripting via the qty parameter in product/fournisseurs.php (critical 9.8)
- [CVE-2018-16809](https://insights.sbomify.com/CVE-2018-16809/): Dolibarr SQL injection via the integer parameters qty and value_unit (critical 9.8)
- [CVE-2018-10094](https://insights.sbomify.com/CVE-2018-10094/): Dolibarr SQL injection vulnerability (critical 9.8)
- [CVE-2018-9019](https://insights.sbomify.com/CVE-2018-9019/): Dolibarr SQL Injection vulnerability (critical 9.8)
- [CVE-2017-14238](https://insights.sbomify.com/CVE-2017-14238/): Dolibarr SQL injection vulnerability in admin/menus/edit.php (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-25954 and fix it if it is affected.

What it is: CVE-2021-25954 is a medium-severity missing authorization vulnerability in dolibarr, published on 9 Aug 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-25954 in the wild and no public exploit code.

Affected packages and fixed versions:
- dolibarr/dolibarr (Packagist): affected from 2.8.1; fixed in 14.0.0
- dolibarr/dolibarr (Packagist): affected from 2.8.1; fixed in 14.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-25954/ (Markdown: https://insights.sbomify.com/CVE-2021-25954/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-25954
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-25954
- OSV: https://osv.dev/vulnerability/CVE-2021-25954

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-25954/
Summaries are generated and may contain mistakes; the official description above is the record.
