# CVE-2021-25955: Stored XSS in “Dolibarr” leads to privilege escalation

> Stored XSS in Dolibarr allows low-privileged users to inject scripts that can steal admin session IDs, leading to account takeover and privilege escalation.

- **Severity:** Critical 9.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Aug 2021
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-cpv8-6xgr-rmf6, UBUNTU-CVE-2021-25955

## What is CVE-2021-25955?

CVE-2021-25955 is a critical cross-site scripting vulnerability in dolibarr, published on 15 Aug 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

In “Dolibarr ERP CRM”, WYSIWYG Editor module, v2.8.1 to v13.0.2 are affected by a stored XSS vulnerability that allows low privileged application users to store malicious scripts in the “Private Note” field at “/adherents/note.php?id=1” endpoint. These scripts are executed in a victim’s browser when they open the page containing the vulnerable field. In the worst case, the victim who inadvertently triggers the attack is a highly privileged administrator. The injected scripts can extract the Session ID, which can lead to full Account takeover of the admin and due to other vulnerability (Improper Access Control on Private notes) a low privileged user can update the private notes which could lead to privilege escalation.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-25955?

2 open source packages ship an affected version, including dolibarr/dolibarr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dolibarr/dolibarr` | Packagist | From 2.8.1 | 14.0.0 |
| `dolibarr/dolibarr` | Packagist | From 2.8.1 | 14.0.0 |

Products: Dolibarr Dolibarr.

## How do I fix CVE-2021-25955?

Upgrade dolibarr/dolibarr to 14.0.0 or later.

## Is CVE-2021-25955 being exploited?

There is no known exploitation of CVE-2021-25955 in the wild and no public exploit code.

## Other vulnerabilities in dolibarr

- [CVE-2019-19212](https://insights.sbomify.com/CVE-2019-19212/): Dolibarr Cross-site Scripting via the qty parameter in product/fournisseurs.php (critical 9.8)
- [CVE-2018-16809](https://insights.sbomify.com/CVE-2018-16809/): Dolibarr SQL injection via the integer parameters qty and value_unit (critical 9.8)
- [CVE-2018-10094](https://insights.sbomify.com/CVE-2018-10094/): Dolibarr SQL injection vulnerability (critical 9.8)
- [CVE-2018-9019](https://insights.sbomify.com/CVE-2018-9019/): Dolibarr SQL Injection vulnerability (critical 9.8)
- [CVE-2017-14238](https://insights.sbomify.com/CVE-2017-14238/): Dolibarr SQL injection vulnerability in admin/menus/edit.php (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-25955 and fix it if it is affected.

What it is: CVE-2021-25955 is a critical cross-site scripting vulnerability in dolibarr, published on 15 Aug 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-25955 in the wild and no public exploit code.

Affected packages and fixed versions:
- dolibarr/dolibarr (Packagist): affected from 2.8.1; fixed in 14.0.0
- dolibarr/dolibarr (Packagist): affected from 2.8.1; fixed in 14.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-25955/ (Markdown: https://insights.sbomify.com/CVE-2021-25955/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-25955
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-25955
- OSV: https://osv.dev/vulnerability/CVE-2021-25955

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-25955/
Summaries are generated and may contain mistakes; the official description above is the record.
