CVE-2021-25957 Account Takeover in "Dolibarr" via Password Reset Functionality
A low-privileged attacker can take over any user account by exploiting flaws in the password reset functionality.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-25957?
CVE-2021-25957 is a high-severity vulnerability in dolibarr, published on 17 Aug 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
In “Dolibarr” application, v2.8.1 to v13.0.2 are vulnerable to account takeover via password reset functionality. A low privileged attacker can reset the password of any user in the application using the password reset link the user received through email when requested for a forgotten password.
Weakness: CWE-640
Which versions are affected by CVE-2021-25957?
2 open source packages ship an affected version, including dolibarr/dolibarr. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
dolibarr/dolibarr Packagist | All versions | 14.0.0 |
dolibarr/dolibarr Packagist | All versions | 14.0.0 |
Products include Dolibarr Dolibarr.
How do I fix CVE-2021-25957?
Upgrade dolibarr/dolibarr to 14.0.0 or later.
Is CVE-2021-25957 being exploited?
There is no known exploitation of CVE-2021-25957 in the wild and no public exploit code.
Other vulnerabilities in dolibarr
- CVE-2019-19212 Dolibarr Cross-site Scripting via the qty parameter in product/fournisseurs.php
- CVE-2018-16809 Dolibarr SQL injection via the integer parameters qty and value_unit
- CVE-2018-10094 Dolibarr SQL injection vulnerability
- CVE-2018-9019 Dolibarr SQL Injection vulnerability
- CVE-2017-14238 Dolibarr SQL injection vulnerability in admin/menus/edit.php
Sources
Also known as GHSA-c32w-3cqh-f6jx, UBUNTU-CVE-2021-25957.