CVE-2021-25959 OpenCRX - Reflected Cross-Site Scripting in Password Reset Functionality
Attackers can execute arbitrary JavaScript in victims' browsers via unsanitized password reset parameters, potentially leading to session hijacking or account takeover.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-25959?
CVE-2021-25959 is a medium-severity cross-site scripting vulnerability in org.opencrx opencrx-core-config, published on 29 Sep 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
In OpenCRX, versions v4.0.0 through v5.1.0 are vulnerable to reflected Cross-site Scripting (XSS), due to unsanitized parameters in the password reset functionality. This allows execution of external javascript files on any user of the openCRX instance.
Weakness: CWE-79
Which versions are affected by CVE-2021-25959?
10 open source packages ship an affected version, including org.opencrx:opencrx-core-config, org.opencrx:opencrx-client and org.opencrx:opencrx-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.opencrx:opencrx-core-config Maven | From 4.0.0 | 5.2.0 |
org.opencrx:opencrx-core-config Maven | From 4.0.0 | 5.2.0 |
org.opencrx:opencrx-client Maven | From 4.0.0 | 5.2.0 |
org.opencrx:opencrx-client Maven | From 4.0.0 | 5.2.0 |
org.opencrx:opencrx-core Maven | From 4.0.0 | 5.2.0 |
org.opencrx:opencrx-core Maven | From 4.0.0 | 5.2.0 |
4 more packages
org.opencrx:opencrx-core-models Maven | From 4.0.0 | 5.2.0 |
org.opencrx:opencrx-core-models Maven | From 4.0.0 | 5.2.0 |
org.opencrx:opencrx-gradle Maven | From 4.0.0 | 5.2.0 |
org.opencrx:opencrx-gradle Maven | From 4.0.0 | 5.2.0 |
Products include Opencrx Opencrx.
How do I fix CVE-2021-25959?
Upgrade org.opencrx:opencrx-core-config to 5.2.0 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2021-25959 being exploited?
There is no known exploitation of CVE-2021-25959 in the wild and no public exploit code.
Other vulnerabilities in org.opencrx opencrx-core-config
Sources
Also known as GHSA-rwh9-8xx8-4wfm.